FreePBX 13 - WAV files won't play

@tm1000 @lgaetz

In an effort to move away from PiAF and install a stand alone version of FreePBX, I decided to warp up a server running CentOS 7 and installing FreePBX 13, following the guide that @tm1000 wrote up. Everything installed successfully. Until I decided to try and play the WAV files on the GUI for MOH. I get this message:

Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
File:/var/www/html/admin/libraries/media/Media/Driver/Drivers/AsteriskShell.php:147

Googling has not turned out anything, nor the forums. Thank you in advance for your cooperation…

Steps to reproduce this error:

Settings > Music on Hold > Edit ‘default’ category > Try to play the WAV file

Asterisk version = 13.6.0
FreePBX version = 13.0.10
CentOS 7.1 x64 bit hosted on Digital Ocean

Sounds like you need to start Asterisk

Thanks for the quick reply, Andrew… But Asterisk is started… I even ran the command service asterisk restart and service asterisk start. However, I noticed that I was running it on Safari browser. Now that I tried it on Chrome, it works. Could this be the cause for an error like that? :astonished:

@tm1000

So, I don’t get the error when I am using Chrome, but I get it when I am using Safari :open_mouth: … weird.

However, if I change settings and click the red Apply Config button from the GUI it vomits this out:

Reload failed because retrieve_conf encountered an error: 1
exit: 1
Unable to connect to remote asterisk (does /var/run/asterisk/asterisk.ctl exist?)
Exception: Unable to connect to Asterisk through the CLI in file /var/lib/asterisk/bin/retrieve_conf on line 24
Stack trace:

  1. Exception->() /var/lib/asterisk/bin/retrieve_conf:24

But line 24 on that file simply says to throw the Exception. It doesn’t really help. Am I looking in the right place? Thanks again for any help with this. Really appreciate it.

The problem is right there ^ Asterisk is not running. It might be running as root but that is just as bad.

[[email protected] ~]# ls -l /var/run/asterisk
total 8
srwxr-xr-x 1 asterisk asterisk    0 Sep 22 13:44 asterisk.ctl
-rw-r--r-- 1 asterisk asterisk    6 Sep 22 13:44 asterisk.pid

Yours is probably “root root” or the folder itself is owned by root.

@tm1000 You are right… when I ran that command, mine shows as root, root… what can I do? Should I destroy and set up the server again following the steps you provided on the wiki? Maybe I missed something…