FreePBX 13 Updates (non-distro)

freepbx
Tags: #<Tag:0x00007f7026de60f0>

(Jake Hassings) #1

Hello,

I’m trying to update some modules on my older FreePBX install, but I’m getting a dependency error when trying to upgrade, e.g. sysadmin:

➜  ~ sudo yum install sysadmin 
Loaded plugins: etckeeper, fastestmirror, langpacks
Loading mirror speeds from cached hostfile
 * base: centos.s.uw.edu
 * extras: sjc.edge.kernel.org
 * updates: mirrors.ocf.berkeley.edu
Resolving Dependencies
--> Running transaction check
---> Package sysadmin.noarch 0:2.8.0-2.shmz65.1.45 will be updated
---> Package sysadmin.noarch 0:5.3-3.0.0.2.2.sng will be an update
--> Processing Dependency: php < 5.4 for package: sysadmin-5.3-3.0.0.2.2.sng.noarch
--> Finished Dependency Resolution
Error: Package: sysadmin-5.3-3.0.0.2.2.sng.noarch (schmooze-commercial)
           Requires: php < 5.4
           Installed: php-5.4.16-36.el7_1.x86_64 (@base)
               php = 5.4.16-36.el7_1
           Available: php-5.4.16-48.el7.x86_64 (base)
               php = 5.4.16-48.el7

Should I manually install an older version of PHP or do I need to update my repo list to include a “post-schmooze” source? Any other suggestions would be greatly appreciated!


(TheJames) #2

I don’t think any of the pre SNG7 stuff is maintained anymore as it is super old. Your best bet would be to pull up to something EL7 based though none of it is supported for commercial modules outside of running the distro. You can use something like remi (https://rpms.remirepo.net/) to install php53-* and see if it helps. In any case it is probably time to upgrade across the board. You can run a backup on freepbx then restore it to a clean install with 15.


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.