FreePBX 13 update modules now can't log on

Just logged in to my FreePBX 13 installation, and selected several modules to update. Now, I get a new login screen and I’m unable to login. I have tried manually inserting a new SHA1 password in the amusers table but that didn’t fix it. I saw a reference to deleting /var/www/html/admin/modules/extensionroutes but that didn’t fix it either. Rebooting doesn’t fix it. Any ideas where I should check next?

I get the following error multiple times in /var/log/asterisk/freepbx.log, if it’s related…

[2015-Apr-28 14:19:42] [PHP-WARNING] (/var/www/html/admin/libraries/ampuser.class.php:55) - in_array() expects parameter 2 to be array, null given

What new login screen?

Problem solved. I did a module update from the command line and told it to update all modules. I was then able to log back in. Obviously a problem with module dependencies where I upgraded one module and not another. As for the new login screen, I think it was a lack of CSS stylesheet. It’s looking normal again after manually upgrading all the modules.

What is the command to update all modules?

/var/lib/asterisk/bin/module_admin upgradeall

1 Like