FreePBX 13 SendRPID during Transfer using Grandstream GXP2160

I am testing FreePBX 13 with Grandstream GXP-2160 phones and can’t get remote party caller ID to follow the call transfer. Used FPBX Distro install & have ran all current module updates and phone Firmware updates.
Example: Caller calls into reception desk and shows caller ID George 614507XXXX. Receptionist transfers the call to Ext 204 and 204 only sees receptionist Ext 200 not inbound caller ID George 614507XXXX.
I have set FreePBX Settings ->Advanced Settings-> SIP trustrpid = Yes and SIP sendrpid = (tried both PAI and Yes)
FreePBX Application -> Extension -> Advanced Tab -> Trust RPID=Yes, Send RPID = (tried both Send P-Asserted and Send Remote Party ID)
In GXP2160 SIP Basic P-Prefered Identity = (tried Default and Yes).
I have been trying to get this working for 2 days without any luck. Can anyone verify that this function works with Version 13 and GXP2160?


Can you make the following changes in sip.conf and test:
sendrpid = yes
trustrpid = no

Can you confirm that rpid works with another phone brand? or a forwarded extension, with no registration to any SIP endpoint?

Can you try to set Sender P-Asserted-Identity Header and test?

If none of the options above helps, I suggest you open a ticket at and our engineers will be glad

I can confirm that rpid works fine on the 2160 using the distro with FreePBX and Asterisk 13. On the phone, Use P-Preferred-Identity Header is set to default, the extension settings are Trust rpid set to yes and Send rpid is set to PAI. I am using firmware version in case that matters.

I tested using the transfer button on the phones as well as the Asterisk feature codes, both work.

Got it working with your settings, but only using the manual feature code ## EXT # It will not work with the transfer button on the phone.
I am testing this with a Distro version (FreePBX version 13) and all current module updates. It was only after reading your message that I tried ## option instead of the transfer button on the phone (silly me).
I will also follow up with my Grandstream support case to inform them of the findings, so they can correct this in future firmware.
Thanks for everyone’s help.