FreePBX 13 Commercial Module Activation error

I am having an issue related to FreePBX 13’s activation issues related to transferring my license to a new deployment. I have tried to reach out to Sangoma Support and I was prompted by their ticketing system that I don’t have an active support system. I am surprised that I haven’t heard from Sangoma Support for what is an issue with their distro and activation server, and not a fault of my own. I have not heard back from them, which really leaves a bad taste.

I’ve run into a license activation error after a restoring a backup from a baremetal server to a vm with the same version freepbx 13. I had everything working fine until I went to activate the new vm instance. I went to sysadmin and then activation. It brought up a prompt and I clicked on new activation, which generated a new ID XYZ2.

After the first activation, I noticed that the Sangoma portal didn’t show any of the licenses transferred to the new deployment ID despite me unlocking the original deployment ID of XYZ through the sangoma portal.

I then tried to reactivate the new vm and I chose existing deployment. While it tried to communicate with the samgoma servers, I received errors in the activation box for failed to restart apache and a retry resulted in a connection timed out. Please see attached screenshots.

While my deployment ID was locked, I just spoke to Steve in sales and he was nice enough to unlock it. I still don’t see the deployment id being unlocked in my portal.

While speaking with Steve this morning, I did run the fwconsole sa activate XYZ on the shell of the VM and it resulted in success.

However, the web interface of the new vm still keeps popping up an activation popup as shown below. I tried to press the activate button and it results in error again. The first time I get a “failed to restart apache” error, and on the second try I get a “connection timed out error.”

Your assistance will be greatly appreciated.

Question - why are you setting up a new 13 system today? It should be on 16.

If you’re keen to proceed on 13, what is the output of

fwconsole sa info

If the deployment ID is correct, then this is not a registration issue, you’re already registered.

Thanks for the reply. My old server on freepbx 13 has been working fine and I wanted to move it to less noisy server. I’ve been putting it off since 2019 and decided to do it now. But to my surprise it is a pain.

fwconsole sa info gets me
Activation Status
Lic File: Present
Deployment: [should I reveal in a public forum?]

You don’t need to share the dep ID, just confirm it is correct when you run that command.

Yes I am using the correct ID. Activating using fwconsole sa activate works fine, says http restart done. But when I login to the freepbx portal I get the activation window and I can’t get out of it.

If there is an issue with restarting services, I think a reboot might be in order, have you tried that already?

yes several times with no change

Are freepbx 13 servers just not able to activate? I tried everything including making the server dmz to make sure it was not a firewall issue, and I even made sure dns is working.

I noticed you commented a similar activation issue in this thread:

Did the developers not fix the issue for FreePBX 13? it looks like they fixed it for 15 and 16 but not legacy versions.

Your system is activated, the issue from what I can see is a fault with sysadmin. I have a very vague memory of hearing about this once before, but not sure. It’s certainly not a common problem. In any case, 13 is nearing EOL, I don’t recommend spending any time setting up a new system that’s not on 16.

With inflation all around us, and costs for doing business higher than usual, I cannot afford to purchase updates. This is a fault of the commercial module activation through the web interface only. I figured it out.

I did not appreciate the insistence by you and your support staff that I should pay to update the module, when I paid for a commercial module in the first place to work especially if it was marketed with a license validity period that is still valid.

Sangoma uses a bait and switch pricing model. It is not clearly apparent on the product descriptions that the licenses require yearly update purchases to continue getting updates.

Simply put, Sangoma’s licensing model is predatory marketing. If you’re going to sell something be transparent about it. When it doesn’t work, support it or fix it.

The issue at hand lies with the commercial module activation, and not the free open source distro.

No thanks to the FreePBX team, the solution, was simple. I am sure there are some other users like myself stuck with an activation window. The issue lies within the web interface of freepbx 13. I can see the fwconsole sa activate [deployment id] works from the cli, and so does the fwconsole sa info command.

Instead of activating the deployment using the web interface, activate the deployment using the CLI only and it works.

I don’t see why such a simple solution derived from logical reasoning could not be proposed by Sangoma Support instead of trying to push a sale.

I think you’ve bent yourself out of shape for nothing. Whilst I’m not a massive fan of some of Sangoma’s work ethics, in this case all that was suggested is that you do a clean install of v16. The only cost involved is your time. Take a back up of your current system, install v16 and restore the backup and activate using the current deployment ID.

The point was that whilst it may have been a simple fix you are leaving yourself vulnerable by trying to remain on an EOL version.

Also the support system isn’t the place for reporting potential bugs anyway. Any support for FreePBX is going to be chargeable as that’s part of the revenue model to support the ongoing development of what is essentially a free to use PBX.

Seems like you are a loyalist. When we pay for something, such as a commercial module, it should get activated regardless of the FreePBX version.

It’s not the module that’s the issue, it’s the GUI as you don’t need to pay for a commercial module to activate the system. Also no software company is going to maintain unlimited back versions of a module for $25. If you don’t like it I suggest you find another Open Source PBX there is nothing stopping you.

I’m far from a loyalist as an ex-employee that quit because of poor sales practices. What I’m not a fan of is people whining about something that’s free to use and probably only pays a few bucks a year for a commercial product.

1 Like


You call spending $600 for something that doesn’t work whining? your opinion is what its worth on this free forum.

I have a valid concern, and attempts to minimize my concerns and those of others like myself that are posting something similar but get no help feed in to the corporate narrative of shrugging their shoulders.

The issue is at hand is with the activation process through the gui. If there is a known issue, that several other users are having like myself, should be resolved.

Not everyone has the need to update.

You may have lots of money and time on your hands to come on a forum and attack people, and tell them they are whining, the rest of us don’t.

Good luck!

Regardless of what you have paid there is a free fix for it which is to upgrade the software to the latest v16. I’m not sure why this is such an issue?

I’m guessing you wouldn’t be complaining about Microsoft not updating a bug in Windows XP, so why do expect this of FreePBX. If you were planning to replace a laptop you wouldn’t just copy your HDD with an EOL OS? For v13 it is unlikely to get any further development work because of it’s age and status. For your own benefit in terms of security and long term support you need to get it to a new version at the very least but if you are going to do something it is best and quickest to do a backup, fresh install of v16 and restore from the backup.

As someone who regularly tries to help out on the forum it’s frustrating when people are given the answer but choose not to follow it and then complain that it’s the fault of the big bad company or some such.

This model has been exactly the same as far back as I can remember. There have been people running v2 of FreePBX that expect the same and haven’t bought a commercial module but that is not sustainable.

There is considerable misunderstanding of how commercial licensing works conflated with an activation issue. My recommendation to set up a new 16 system still stands. Your original licensing purchases will work on 16 just as they do on 13, even if you choose not to renew the maintenance. Renewing maintenance entitles you to support and module updates. If you need another activation reset, they can be requested via a support ticket of type ‘customer service and billing’ which does not require any credit.


@lgaetz Please note your support techs state you have to purchase updates to migrate commercial modules purchase during the time of FreePBX 13. You’re saying that is not the case. If I was informed of “Your original licensing purchases will work on 16 just as they do on 13, even if you choose not to renew the maintenance” I would not have wasted so much time trying to get my v14 server to work.

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.