Freepbx 13 and send-to sources in Superfecta module : no longer working?


(Kim) #1

Hi,

I’m testing vultr server with freepbx 13 image, and enjoyed really my configuration (9 trunks, 20 extensions).

Just having ONE issue with Cid Superfecta (updated to last 13.0.41) which seems no longer sending caller details to send-to sources, send-to-growl in my case.

this worked in debug mode correctly with Superfecta 13.0.31, but NOT AT ALL with inbound routes in production.

Have read this thread superfecta under freepbx forum few months ago, but Lorne advice didn’t worked for me (“Try ordering your Send-to source(s) above your lookup source(s):confused:

Had googled around, but seems no fix for this, anyone could hlep plz ? :disappointed_relieved:
Big thank for any help!

  • my configuration is very simple : i’m using Asterisk phonebook source, and send-to-growl module,
  • in debug mode (with last superfecta 13.0.41) : i have this in window
    {“error”:{“type”:“Whoops\Exception\ErrorException”,“message”:“Uninitialized string offset: 0”,“file”:"/var/www/html/admin/modules/superfecta/includes/processors/superfecta_single.php",“line”:30}}

in Asterisk logfiles i noticed this detail :

[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: Launched AGI Script /var/www/html/admin/modules/superfecta/agi/superfecta.agi
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: Executing Scheme..
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: Scheme Asked is: Default
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: The DID is: 00XXXXXXXXXXX
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: The CNUM is: YYYYYYYYYY
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: The CNAME is: 510
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi:
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: /var/www/html/admin/modules/superfecta/agi/superfecta.agi: Starting scheme Default
[2017-11-11 23:50:36] VERBOSE[14091][C-00000027] res_agi.c: <SIP/trunk-name-00000028>AGI Script /var/www/html/admin/modules/superfecta/agi/**superfecta.agi completed, returning 0**

(Kim) #2

Hi,

seems as no one is around ?

Plz any help :sob:


(Dave Burgess) #3

We are around, but we’re not your servants.

This was asked and answered in another thread just the other day. Try the search function and see what the solution was there.


(Kim) #4

Thank you @cynjut for your kind reply, i agree totally with you, no one here is servant of others,

I’m writing for a lot of search mainly in your nice forum, as i mentioned in my request. Will check again, thanks


(Guido Leenders) #5

Same problem here since last upgrade.

Removed all sources except the source-Send_to_URL.module source. Still not working.

Added debugging.

The superfecta single calls the source. But it does not implement get_caller_id. Found that the includes/superfecta_base.get_caller_id is actually called, which is a no operation.

In the source-Send_to_URL.module there is a function post_processing. This function is never called when I choose ‘run scheme’ from freepbx.

After adding following code to source-Send_to_URL.module it works again:

    function get_caller_id($thenumber, $run_param=array()) {

print ‘get caller id’;
$this->DebugPrint(“Searching " . str_replace(”_", " “, get_class($this)) . " …”);
//Is this the best way to do this?

                    $url = $run_param['URL_address'];
                    $url = str_replace('[NUMBER]', urlencode($thenumber), $url);
                    $url = str_replace('[number]', urlencode($thenumber), $url);
        $this->DebugPrint("Send to URL: {$url}");

        $value = $this->get_url_contents($url);
        return ($value);
}

(Vincent) #6

I am having this issue with asterisk 15. It was working fine with asterisk 13, now not with this. is there a setting I need to change for url lookup to work again? I know the url works if I paste it in the browser.
When I do a debug test for the cid superfetcha the URL is not sent.

Thank you for your help


(Lorne Gaetz) #7

I’m not having any issues. Send to URL works as expected in 15 as do other send to sources.


(Vincent) #8

Solution:
After some trouble shooting, it seems like the send to URL feature needs some sort of caller ID name info before it works. If its just the number, it won’t send the number to the URL.
So my CNAM was spent, so I re-enabled the geo location and trunk CID info, and right away the URL was being sent the correct number.

Thanks for the help!