FreePBX 13.0.131 "Attempted calls"


I’m running my first FreePBX and it’s be wonderfully saving me money compared to the landline from Virgin Media.

One issue I seem to have is when looking at the Dashboard page, it shows calls many calls which I have not made. I keep a careful eye on the balance / call history in my SIP account and so I know that none of these have been successful so far but wondering if anyone can help me sure up my firewall settings to I can get rid of these attempted calls. Sometimes there are one or two but on several occasions I have seen that number jump to 50-90+ calls where I guess the nasty person is attempting to brute force / cause an overflow buffer type exception.

I have my PBX running on stand alone hardware with the Firewall and Fail2Ban modules enabled. I have a good router with a firewall enabled which I think is correct.

When I “nmap -sU” the FreePBX host inside my network it takes an age to respond but eventually returns the results including port 5060 for sip (although is does say this is filtered). When I “nmap -sU” against my external IP then I just get a single result “520/udp closed route”


Do you have the Responsive Firewall enabled? If you do it means it opens up to SIP messages to allow for registration attempts.

Double check your General SIP Settings and your Chan_SIP/Chan_PJSIP settings to make sure that “Allow Anonymous Callers” and “Allow SIP Guests” are set to off. If those are on you’re just allowing anyone to try and connect to send calls.

Luckily for you FreePBX automatically will dead route calls that don’t come from a real user.

1 Like

Tom, Thanks for your prompt response.

Yes, the Responsive Firewall is enabled and looking at the Chan_SIP settings, I had “Allow SIP Guests” enabled. I have disabled this now and applied the config changes. In ~2 hours it should be clear whether this change will have a positive affect on my environment and so I shall update this thread.