Freepbx 12 sangoma A200 line always "uninitialized"

hi folks
asterisk 13 with sangoma a200

asterisk detect everything but status of line always “uninitialised”

[[email protected] ~]# watch -n 1 “wanpipemon -i w1g1 -c astats -m 3”
Every 1.0s: wanpipemon -i w1g1 -c astats -m 3 Thu May 17 20:57:05 2018

    ------- Voltage Status  (FXO,port 2) -------

VOLTAGE : 51 Volts

    ------- Line Status  (FXO,port 2) -------

Line : uninitialized

[[email protected] ~]# asterisk -rvvvv
Asterisk 13.21.0, Copyright © 1999 - 2014, Digium, Inc. and others.
Created by Mark Spencer [email protected]
Asterisk comes with ABSOLUTELY NO WARRANTY; type ‘core show warranty’ for details.
This is free software, with components licensed under the GNU General Public
License version 2 and other licenses; you are welcome to redistribute it under
certain conditions. Type ‘core show license’ for details.

Connected to Asterisk 13.21.0 currently running on localhost (pid = 4475)
localhostCLI> core show version
Asterisk 13.21.0 built by root @ localhost.localdomain on a x86_64 running Linux on 2018-05-16 19:26:43 UTC
localhost
CLI> dahdi show ch
channel channels
localhostCLI> dahdi show channels
Chan Extension Context Language MOH Interpret Blocked In Service Description
pseudo default default Yes
1 from-internal en default Yes
2 from-analog en default Yes
3 from-analog en default Yes
4 from-analog en default Yes
localhost
CLI> dahdi show version
DAHDI Version: 2.10.0 Echo Canceller:
localhost*CLI>

[[email protected] ~]# wanrouter restart

Shutting down wanpipe1 interface: w1g1
Shutting down device: wanpipe1

    wanconfig: WAN device wanpipe1 did not shutdown
             : ioctl(wanpipe1,ROUTER_DOWN) failed:
             :      16 - Device or resource busy


    If you router was not running ignore this message

!! Otherwise, check the /var/log/wanrouter and
/var/log/messages for errors

Devices Still Running:
wanpipe1

Error: Device wanpipe1 is already running
Run ‘wanrouter stop wanpipe1’ first

Configuring interfaces: w1g1
done.
Waiting for Dahdi /dev/dahdi …
Loading DAHDI hardware modules:
wct4xxp: [ OK ]
wcte43x: [ OK ]
wcte12xp: [ OK ]
wcte13xp: [ OK ]
wct1xxp: [ OK ]
wcte11xp: [ OK ]
wctdm24xxp: [ OK ]
wcaxx: [ OK ]
wcfxo: [ OK ]
wctdm: [ OK ]
wcb4xxp: [ OK ]
wctc4xxp: [ OK ]
xpp_usb: [ OK ]

D: auto ‘/sys/bus/dahdi_devices/devices/wanpipe_devices:wanpipe1’
auto-assign /sys/bus/dahdi_devices/devices/wanpipe_devices:wanpipe1
Running dahdi_cfg: [ OK ]
DAHDI Tools Version - 2.10.0

DAHDI Version: 2.10.0
Echo Canceller(s):
Configuration

4 channels to configure.

Setting echocan for channel 1 to none
Setting echocan for channel 2 to none
Setting echocan for channel 3 to none
Setting echocan for channel 4 to none

[[email protected] ~]# cat /etc/asterisk/chan_dahdi.conf

[general]

#include chan_dahdi_general.conf

#include chan_dahdi_general_custom.conf

[channels]
language=en
busydetect=no
busycount=6
usecallerid=yes
callwaiting=yes
usecallingpres=yes
threewaycalling=yes
transfer=yes
cancallforward=yes
callreturn=yes
echocancel=no
echocancelwhenbridged=no
echotraining=no
immediate=yes
faxdetect=both
rxgain=0.0
txgain=0.0

#include chan_dahdi_channels_custom.conf

#include chan_dahdi_groups.conf

#include chan_dahdi_additional.conf

[[email protected] ~]# cat /etc/asterisk/dahdi-channels.conf

; Span 1: WRTDM/0 “wrtdm Board 1” (MASTER)
;;; line=“1 WRTDM/0/0 FXSKS (In use)”
signalling=fxsls
callerid=asreceived
group=0
context=from-pstn
channel => 1
callerid=
group=
context=default

;;; line=“2 WRTDM/0/1 FXSKS (In use)”
signalling=fxsls
callerid=asreceived
group=0
context=from-pstn
channel => 2
callerid=
group=
context=default

;;; line=“3 WRTDM/0/2 FXSKS (In use)”
signalling=fxsls
callerid=asreceived
group=0
context=from-pstn
channel => 3
callerid=
group=
context=default

;;; line=“4 WRTDM/0/3 FXSKS (In use)”
signalling=fxs_ks
callerid=asreceived
group=0
context=from-pstn
channel => 4
callerid=
group=
context=default

any help ?

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.