FreePBX Yum Update Issue


I have been checking over the last couple of weeks for an update to FreePBX to address the Asterisk vulnerabilities AST-2017-005, 006 & 007. Last week the asterisk11-core.x86_64 0:11.25.2-1.shmz65.1.122 package was released and everything was OK (no errors in yum update reported). I planned to peform the work today as I have never updated a FreePBX server before, so I imaged the server and started the yum update process. Unfortunately now I get two errors as follows:

Error: Package: asterisk11-core-11.25.2-1.shmz65.1.122.x86_64 (pbx)
Removing: libsrtp-1.4.4-4.20101004cvs.el6.x86_64 (@anaconda-PBX-201403180405.x86_64/6.5)
Updated By: libsrtp-1.5.4-3.el6.x86_64 (epel)
Not found
Error: Package: asterisk11-core-11.25.2-1.shmz65.1.122.x86_64 (pbx)
Removing: libresample-0.1.3-11_centos6.x86_64 (@anaconda-PBX-201403180405.x86_64/6.5)
Updated By: libresample-0.1.3-12.el6.x86_64 (epel)
Not found

I think these errors relate to the server having multiple yum repositories defined, it currently has the FreePBX, Fedora and Dell repositiories defined, having inherited the server I am not too sure why these repositoires have been defined (the Dell one I know it was to install the Dell Linux services so the server can be monitored by Opsview), Fedora may have been defined as the Dell Linux services require something that was not in the FreePBX repository…

I tried to resolve the issue by attempting to update the two packages above first but this fails with a RPM error which I think is because the versions will break the current version of FreePBX (or the update process removes and then installs the newer version which is not being allowed because FreePBX depends on the package), the error is below:

Running rpm_check_debug
ERROR with rpm_check_debug vs depsolve: is needed by asterisk11-core-11.25.2-1.shmz65.1.122.x86_64
You could try running: rpm -Va --nofiles --nodigest
Your transaction was saved, rerun it with: yum load-transaction /tmp/yum_save_tx-2017-09-16-11-35p64Bj_.yumtx

Not being too good with Linux how do I update FreePBX without breaking the whole product?


After two years here comes finally an answer. :wink:

I run into the same issue regarding that strange “Error: Package … Requires:” message. The solution was quite easy, - I had to remove the EPEL repository:

yum remove epel-release

After this yum update runs perfectly. :grinning: