FreePBX 10.13.66-6 SSH Login PHP Errors

When I login as myself (not root) I get the following errors
I did yum update, updated all modules through the GUI, and ran fwconsole download/install
I have a fresh machine install (registered) as well as a copy on a VM and they both give the same error

PHP Warning: include_once(/etc/asterisk/freepbx.conf): failed to open stream: Permission denied in /var/lib/asterisk/bin/fwconsole on line 13
PHP Warning: include_once(): Failed opening ‘/etc/asterisk/freepbx.conf’ for inclusion (include_path=’.:/usr/share/pear:/usr/share/php’) in /var/lib/asterisk/bin/fwconsole on line 13
PHP Fatal error: Class ‘Symfony\Component\Console\Application’ not found in /var/www/html/admin/libraries/FWApplication.class.php on line 11

Any ideas?

fwconsole chown

Will fix it

Do I run it as root or as myself?

I assumed as root and ran it, but when I log in as myself I still the error

What do you mean “logging in as yourself”. You should be logging in as Root. Anything else is unsupported. You’ll need to remove the motd file manually.

For all of our Linux machines we normally log in as a sudo/wheel user and sudo where needed
When I log in as root I do not get errors but if I log in with my user credentials (cjacobsen) I get the PHP errors “at login”.

On my FreePBX asterisk 11 machine logging as cjacobsen I do not get errors so I assume that in the new distro I also should not get errors.

I ran the fwconsole chown as root

I am not sure what you mean by remove the motd file manually

The new MOTD files requires Asterisk user permissions. If you don’t want to see the error you need to remove the MOTD file when you login as cjacobsen

Okay thanks Andrew, as long as it isn’t causing any problems I am fine with ignoring it.

I really appreciate your help and was glad when I saw it was you who replied. Now I can go back to having fun with my new toy.

Have a nice holiday

1 Like

Nope. No problems…