FreePBX-1.1005.210.62-x86_64-Full-1339442617.iso issues I stumbled over

Just a few things I have noticed when trying the FreePBX-1.1005.210.62-x86_64-Full-1339442617.iso today:

  1. Issues with ZendGuardLoader in 64 bit distro:
    the path in to teh ZendGuardLoader is wrong in the /etc/php.d/zendguard.ini file. After installation, it was set to:
    zend_extension=/usr/lib/php/modules/ZendGuardLoader.so

however it should have been:
zend_extension=/usr/lib64/php/modules/ZendGuardLoader.so

this caused the pbx_first_boot.sh script to fail.

  1. Problem with Symlink in loger.conf - the same problem had been described here:
    http://www.freepbx.org/forum/freepbx-distro/distro-discussion-help/symlink-from-modules-failed#comment-52442

  2. Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly
    Added 13 minutes ago
    (framework.ASTCONFAPPMISSING)

This one I have not figured out yet, all the other ones I was able to work around.

Please let me know if there is a better place to report such findings or if I can assist in more testing

After installing BETA-1.1005.210.62 (64bit) serveral times i’m very sad. The distro is realy broken. The first install.sh finishes in errors.

The BETA-1.1005.210.62 has problems with ZendGuardLoader as posted by nbsberlin but there are more isues. Trunks will not register. If I run a netstat -tanp there is no listen port 5060.

I installed the stable versions a lot of times without problems but we need the Centos 6 versions because the CentOS 5.8 version will not run under a KVM VM (proxmox).

I hope the stable distro version will be published soon under Centos 6.

Does anyone have the same problems (i can give details if needed)?

Gr.

Edwin

Ok well I have the zend issue fixed and working on the app meet-me now. Not sure why that is failing but not on 32bit.

Thanks Tony for your hard work on this.

In the meantime I have also tried the 32 bit distro’s:

The Net Install did not run any of the freepbx scripts, so not even asterisk was installed, I have not investigated if there was a network problem in between or what went wrong.

The full install did run through and freepbx was installed and freepbx was up and running, so was asterisk. However as Edwin noticed - there was no port allocated by asterisk. I do need to check a bit more as to what is going on there and hope I can provide more information soon.

Best regards

Today I installed FreePBX-1.1005.210.62-x86_64-Full-1343004062.iso to check if all isues are solved. Because I’m runing a VM under KVM choose the advanced method and created 2Gb Swap, 2GB /var/log and 8GB /.

After setup the firstboot script ran into errors again.

I checked the /var/log/pbx/install/firstboot.log and will post the error part:

Enable modules that in 2.10 are not being enabled from the RPM

sudo -u asterisk /var/lib/asterisk/bin/module_admin enable fw_ari

  • sudo -u asterisk /var/lib/asterisk/bin/module_admin enable fw_ari
    The following error(s) occured:
  • Module fw_ari is already enabled
    sudo -u asterisk /var/lib/asterisk/bin/module_admin enable framework
  • sudo -u asterisk /var/lib/asterisk/bin/module_admin enable framework
    The following error(s) occured:
  • Module framework is already enabled
    sudo -u asterisk /var/lib/asterisk/bin/module_admin disable userpaneltab
  • sudo -u asterisk /var/lib/asterisk/bin/module_admin disable userpaneltab
    The following error(s) occured:
  • Specified module not found
    sudo -u asterisk /var/lib/asterisk/bin/module_admin disable fw_fop
  • sudo -u asterisk /var/lib/asterisk/bin/module_admin disable fw_fop
    The following error(s) occured:
  • Specified module not found
    sudo -u asterisk /var/lib/asterisk/bin/retrieve_conf
  • sudo -u asterisk /var/lib/asterisk/bin/retrieve_conf
    [FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting
    sudo -u asterisk /var/lib/asterisk/bin/module_admin reload
  • sudo -u asterisk /var/lib/asterisk/bin/module_admin reload
    Error(s) have occured, the following is the retrieve_conf output:
    exit: 1
    [FATAL] Unable to connect to Asterisk Manager from /var/lib/asterisk/bin/retrieve_conf, aborting

pull in all freepbx modules and load them

which amportal chown
which amportal
++ which amportal

  • /usr/local/sbin/amportal chown

Please wait…
<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<<

I did a yum upgrade / reboot and tried again but the result was the same.

In the /var/log/asterisk/full log I see this error:
VERBOSE[1596] asterisk.c: Asterisk Ready.
NOTICE[1810] manager.c: They didn’t equal? amp111 != f8XKACOoEBoU ?
WARNING[1810] security_events.c: Required IE ‘50’ for security event type ‘12’ not present
NOTICE[1810] manager.c: 127.0.0.1 failed to authenticate as ‘admin’

It looks like the this line in pbx_first_boot.sh gives the error:
sudo -u asterisk /var/lib/asterisk/bin/retrieve_conf

Reason AMPMGRPASS is set wrong, in my /etc/amportal.conf it is set to f8XKACOoEBoU.

Even after changing this to amp111 freepbx gives me errors and udp port 5060 is not present

Hope we can solve this issues quickly, if more info is needed please let me know.

Gr.

Edwin

I just installed FreePBX-1.1005.210.62-x86_64-Full-1343004062.iso with no issues. Can someone else test. Sounds like something is not setting right with your virtual setup.

I am sorry I was testing 1.1006.210.62-x86_64 is where I made those changes. I guess they never got published. Check the download site in a few hours and they should be there.

Ok the 1.1006.210.62 32bit and 64 have been pushed and synced. Please test and let me know if you have any issues.

Thanks for looking into this Tony, downloading now. I will report back later today.

Tony,

Today I installed 1.1006.210.62 (64bit), the pbx_first_boot.sh finished without errors this time, was deleted and the machnine rebooted.

After this the freepbx gui look OK but udp port 5060 was not there! In the /var/log/asterisk/full log there were still errors.

WARNING loader.c: Error loading module ‘pbx_config.so’: /usr/lib/asterisk/modules/pbx_config.so: cannot open shared object file: No such file or directory
WARNING loader.c: Error loading module ‘chan_local.so’: /usr/lib/asterisk/modules/chan_local.so: cannot open shared object file: No such file or directory
WARNING loader.c: Error loading module ‘chan_local.so’: /usr/lib/asterisk/modules/chan_local.so: cannot open shared object file: No such file or directory

I fixed this by (i’m using the 64bit version) editing the asterisk.conf file changing:
astmoddir => /usr/lib/asterisk/modules
in
astmoddir => /usr/lib64/asterisk/modules

The same error was in extensions_additional.conf and amportal.conf…

The system was also repining about the writetimeout in the manager.conf:
WARNING manager.c: Invalid writetimeout value ‘’ at line 19
I disabled this line:
[admin]
;writetimeout =

Now the systems looks fine (at first glance), hope my comment was usefull…

Gr.

Edwin

I did go for installing the 32 bit version.

Installation worked (almost) without a problem. Only thing was the IP I had entered manually was not taken, the system defaulted to DHCP.

Besides that the install run through, the web portal was up and running.

Once logged into the web portal I did gettwo error messages, one for a symlink to the logger.conf (easy fixable) and one about having to make a decision between app_meetme and conferences - the later went away after the first config change.

On to setting up an extension, this also worked without a problem and I could connect a phone (netstat had revealed port 5060 is up and listening).

Now I just have to figure out why I don;t get any audio (e.g. when dialing *65). I do see in the logs that the commands are fully executed but I don;t hear anything.

I also see a lot of “NOTICE[2681] manager.c: Seems to have passed…” messages in the log file, not sure if they have anything to do with it.

I also found a few more error messages in the log file:
[2012-07-30 17:20:16] WARNING[1366] pbx.c: Context ‘from-did-direct’ tries to include nonexistent context 'ext-findmefollow’
And much more similar, usually they do not hurt…

[2012-07-30 17:20:16] WARNING[1366] manager.c: Invalid writetimeout value ‘’ at line 19

[2012-07-30 17:20:16] NOTICE[1366] loader.c: 216 modules will be loaded.
[2012-07-30 17:20:20] WARNING[1366] res_jabber.c: No such configuration file jabber.conf
[2012-07-30 17:20:20] ERROR[1366] res_jabber.c: JABBER: Failed to load config.
[2012-07-30 17:20:20] WARNING[1366] res_stun_monitor.c: Unable to load config res_stun_monitor.conf
[2012-07-30 17:20:20] NOTICE[1366] res_smdi.c: Unable to load config smdi.conf: SMDI disabled
[2012-07-30 17:20:20] NOTICE[1366] res_smdi.c: No SMDI interfaces are available to listen on, not starting SMDI listener.

[2012-07-30 17:20:20] ERROR[1366] pbx_lua.c: Error loading extensions.lua: cannot open ‘/etc/asterisk/extensions.lua’ for reading: No such file or directory

There are a lot more, should I send you the entire log file?

Thanks again for your quick response…

All those notices can be ignored. The only odd one is WARNING[1366] manager.c: Invalid writetimeout value ‘’ at line 19

That is something FreePBX will need to look at as its a Asterisk 10 thing from my understanding. Not anything we do or touch with the Distro

I can look into why asterisk.conf is wrong but that is part of Asterisk install so we might have to fix the include of that file.

What do you mean by “The same error was in extensions_additional.conf and amportal.conf…”

After gettingthe IP setting straight and configure RTP, I do now have sound. So it does look good!

Ok and I found the issues with Asterisk in EL6 with 64bit. We have to change the spec files for the RPM so I will have new ones tomorrow done and a new ISO built and pushed to the mirrors.

EL6 made some major changes for 64bit from el5

Today I installed FreePBX-1.1006.210.62-x86_64-Full-1343834516.iso

There are still some minor issues:
iSymphony is not running, I had to download java and reinstall:
yum remove jre
yum install jre.x86_64 0:1.7.0_05-fcs

logs are complaining /etc/asterisk/logger.conf is not a symlink:
rm -rf /etc/asterisk/logger.conf
ln -s /var/www/html/admin/modules/core/etc/logger.conf /etc/asterisk/logger.conf
amportal reload

If i find more issues I wil post them…

gr.

Edwin

I am aware of the java issue and working on that. The symlink issue was a FreePBX rpm issue but removing the file and just doing a reload would recreate the symlink for you. You do not have to create the link manually.

Both should be resolved later today on the new build I am working on.

Tony,

Just installed 1.1006.210.62, 32-bit version and get this error on the dashboard:

No Conference Room App

Neither app_meetme nor app_confbridge is configured in Asterisk, conferencing, paging and other functionality will not work properly
Added 5 minutes ago
(framework.ASTCONFAPPMISSING)

Help!
Thanks,

Yes but if you clear the error it does not come backup up and meetme is there.