Free PBX will not update config files in trixbox 2.0- SOLVED

I recently upgraded my asterisk version, back in March, to 1.2.17. I updated freePBX at the same time. I only verified everything operational (making calls, sound, etc.) after making the update. Now over a month later, I go to add an extension and make changes to my dial plan and I find that changes in Free PBX are saved in the database, but not in the conf files.

I had also changed my manager and database user passwords per the instructions over a month ago as well.

I am able to connect to mysql with the passwords in the conf files.

I tried to run the free PBX update again with freshly downloaded files, and get these results: (2.2.1)

Checking for PEAR DB…OK
Checking for PEAR Console::Getopt…OK
Running module install.php and install.sql scripts
Checking for /etc/amportal.conf…OK
Reading /etc/amportal.conf…OK
Reading /etc/asterisk/asterisk.conf…OK
Connecting to database…FAILED
[FATAL] Cannot connect to database
Generating AMP configs…OK
Restarting Flash Operator Panel…OK

Any help or suggestions would be greatly appreciated.


this has been an issue in the past because of different parsers embedded in retrieve_conf. It is resolved (hopefully) going forward in 2.3 where retrieve_conf uses the same included parser as the rest.

Keep the passwords below a certain number of characters (10) and only alpha-numeric to be safe. Once I changed my password to something much more hackable, I was once again able to perform updates. I literally had to go back and resubmit all data on each screen in freepbx, to ensure nothing was missing in the conf files.