Framework breaks permissions

Hi all!

I`ve updated fremework to 13.0.33 from 13.0.11 and now I have a bunch of problems.

Problems are:

Reload failed because retrieve_conf encountered an error: 126

Last login: Thu Dec 17 09:16:42 2015 from
This account is currently not available.
-bash: /var/lib/asterisk/bin/fwconsole: Permission denied

Reload failed because retrieve_conf encountered an error: 126
exit: 126
sh: /var/lib/asterisk/bin/retrieve_conf: Permission denied

1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

It seems that upgrade somehow borks the /var/lib/asterisk/bin folder and do not set chmod +x correctly on files.
When I upgraded and reloaded conf everything is OK bad things start to happen after reboot. Also Asterisk 13 is NOT started at boot time after framework update.

We use:
PBX Firmware:10.13.66-6
PBX Service Pack:

Can someone check what happened with framework?


At the CLI try:

fwconsole chown

Also check the list of modules in Module Admin and ensure that none are still set to ‘disabled pending upgrade’.

Hi lgaetz!
That did the trick.

Will I have to do it every time FW updates?


1 Like

No. There was a glitch on your system.

Hi Guys , this is all not working for me. If i try to Apply Config i get - exit: 126
sh: 1: /var/lib/asterisk/bin/retrieve_conf: Permission denied

If i try fwconsole i get below errors, please help

fwconsole chown

Whoops\Exception\ErrorException: Methods with the same name as their class will not be constructors in a future version of PHP; modulelist has a deprecated constructor in file /var/www/html/admin/libraries/modulelist.class.php on line 3
Stack trace:

  1. Whoops\Exception\ErrorException->() /var/www/html/admin/libraries/modulelist.class.php:3
  2. Whoops\Run->handleError() /var/www/html/admin/
  3. require_once() /var/www/html/admin/
  4. fpbx_framework_autoloader() :0
  5. spl_autoload_call() /var/www/html/admin/libraries/modulefunctions.class.php:641
  6. module_functions->getinfo() /var/www/html/admin/libraries/utility.functions.php:1352
  7. _bootstrap_parse_hooks() /var/www/html/admin/libraries/utility.functions.php:1328
  8. bootstrap_include_hooks() /var/www/html/admin/bootstrap.php:318
  9. require_once() /etc/freepbx.conf:9
  10. include_once() /var/lib/asterisk/bin/fwconsole:12

Your version of php is too high for freepbx 13

Ok, which version should i run and i have already in stall php7.0

If i downgrade , will it not break everything , whats the best way to downgrade

any command i run now its giving that error

amportal chown

not working as well

If i downgrade , will it not break everything , whats the best way to downgrade

Php 5.3 is the only supported version for freepbx 13

I am running ubuntu 16.04 LTS will php 5.3 run on this version of ubuntu? I am trying its failing to install

Are there specific files that are suppose to be php5.3 or the whole php

Please help

Freepbx 13 only supports php 5.3. I can’t give you more information because every distro is different. If you want something that works out of the box you should use the freepbx distro.

what about freepbx 14 , can it work with php7.0

i am getting these errors , i am on ubuntu 16.04TLs, php7.0 freePBX 14 and asterisk-13. Please help

No version of freepbx supports php 7

OK, can i then use php5.6 on this freepbx 14. Does it work ?

Or its has to be php5.3 even for freePBX 14


[and some filler]

Thank you igaetz, everything is working with freepbx 14, asterisk-14, php5.6.28 ON UBUNTU 16.04 LTS and there is issue with permission on /var/www/html directory which you did not included in your installation instructions.

The dir has to be owned by asterisk recursive and chmod 775 recursive. This was a really mission to get it work on ubuntu 16.04 LTS.

Thank you for your help guys, you and tm1000