Framework 2.3.1.0 Files "Not Required"

I’m still checking out the updated framework (thanx for control over Module Admin), but I’m curious as to the upgrade procedure… when it copied over, I got a whole 'lot of “Not Required”. Is this normal, is something wrong, and what is the purpose?

  • J

[code]
Downloading framework 2398675 of 2398675 (100%)
Untarring..Done.
Checking for upgrades..1 found
Upgrading to 2.3.1..
-> Running PHP script /var/www/html/admin/modules/framework/upgrades//2.3.1/removefiles.php
Cleaning up deprecated or moved files:
Checking /var/www/html/recordings/modules/help.module..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/recordings/modules/help.module..Not Required
Checking /var/www/html/admin/bounce_op.sh..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/bounce_op.sh..Not Required
Checking /var/www/html/admin/logout.php..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/logout.php..Not Required
Checking /var/www/html/admin/footer.php..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/footer.php..Not Required
Checking /var/www/html/admin/images/background-grid.png..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/images/background-grid.png..Not Required
Checking /var/www/html/admin/images/background-triangle.png..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/images/background-triangle.png..Not Required
Checking /var/www/html/admin/common/jquery.js..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/common/jquery.js..Not Required
Checking /var/www/html/admin/common/jquery.tabs.js..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/common/jquery.tabs.js..Not Required
Checking /var/www/html/admin/common/freepbx.css..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/common/freepbx.css..Not Required
Checking /var/www/html/admin/common/jquery.interface.js..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/common/jquery.interface.js..Not Required
Checking /var/www/html/admin/common/jquery.tabs.css..Not Required
Checking /var/www/html/admin/modules/framework/htdocs/admin/common/jquery.tabs.css..Not Required
Checking /var/lib/asterisk/bin/retrieve_queues_conf_from_mysql.pl..Not Required
Checking /var/www/html/admin/modules/framework/bin/retrieve_queues_conf_from_mysql.pl..Not Required
Checking /var/lib/asterisk/bin/retrieve_zap_conf_from_mysql.pl..Not Required
Checking /var/www/html/admin/modules/framework/bin/retrieve_zap_conf_from_mysql.pl..Not Required
Checking /var/lib/asterisk/bin/retrieve_sip_conf_from_mysql.pl..Not Required
Checking /var/www/html/admin/modules/framework/bin/retrieve_sip_conf_from_mysql.pl..Not Required
Checking /var/lib/asterisk/bin/retrieve_iax_conf_from_mysql.pl..Not Required
Checking /var/www/html/admin/modules/framework/bin/retrieve_iax_conf_from_mysql.pl..Not Required
Upgrading to 2.3.1..OK
[/code]

it’s fine - it doesn’t need to remove those because they were already removed.

Philippe Lindheimer - FreePBX Project Lead
http//freepbx.org - IRC #freepbx

I’m lovin this ability to update everything and see changelog via module admin! Very nice refinement!

I would imagine that those are files which are used in the 2.3.x Web GUI (or whatever version it was which changed the logo to the frog.) If this is the case and you are already using the new GUI, you wouldn’t need to upgrade those files (or install them) so it should, of necessity, let you know that they aren’t required.

I could be way off the mark here, but that just seems to be what those files would be associated with.