Framework 12.0.14 update causes security warning

Asterisk 12.6.1 / FreePBX 12.0.14 / 6.12.65-22

Just finished the Framework module update and get this;
Module: FreePBX Framework, File: /usr/local/sbin/amportal altered (You may need to run “amportal chown”)

Running amportal chown did not fix.

Ran "amportal a ma refreshsignatures"
We’re all good now.

1 Like

Thank you I went from .13 to .17 and had the same problem and the same thing fixed it.

Really you should run

amportal chown
amportal a r
1 Like

This solved it for me! THank you. I did both, first the amportal a ma refreshsignatures and then I read Andrew’s reply and did the amportal chown and amportal a r. Now the security warning is gone.

Would it not be a good idea then to make the message say the below?

You may need to run “amportal chown” followed by amportal a r

Helped clear the warning when updated to 12.0.17
(12.0.17: Set button default value to a truth false, not a truthy false)

What button? Please file a report at

That’s your description of the changes in the framework update

+1 to what OPTN said. If this was a test whether anybody reads these changelogs, yes we are. :slight_smile:

Just updated another system and had the same tampered file message and I can confirm that running these worked:

amportal chown
amportal a r

What does “amportal a ma refreshsignatures” actually do? Is there somewhere I can read about these commands?

1 Like

I have exactly the same problem : Module: FreePBX Framework, File: /usr/local/sbin/amportal altered (You may need to run “amportal chown”)

this command

amportal chown
amportal a r

do nothing for me.
Always same error.


P.S. FreePBX 12.0.38

Here’s a more in-depth explanation of what’s going on here.

That error is triggered by amportal FAILING integrity validation. As that is a root-owned script, we can’t fix it through the web, so you need to run a chown (where we fix that) manually.

If, for whatever reason, the move is failing, the easiest thing to do is just fix it yourself, manually. Delete the file /usr/local/sbin/amportal, and copy /var/lib/asterisk/bin/amportal into place…

rm -f /usr/local/sbin/amportal
cp /var/lib/asterisk/bin/amportal /usr/local/sbin/amportal

If it’s STILL ERRORING, then that means that - for whatever reason - the file /var/lib/asterisk/bin/amportal couldn’t be written to as part of a Framework upgrade.

Thanks Rob,
now the error it’s gone :smile:

I don’t know why, but In my case /usr/local/sbin/amportal was a symlink and not a copy of /var/lib/asterisk/bin/amportal
I’ve try several time to delete it and make a new symlink, but obviously the error remain
Now i’ve copy the file and everything it’s ok

Thank you very much, I was really close to the a clean installation :smiley:

1 Like