FreePBX | Register | Issues | Wiki | Portal | Support

FPBX13 RC, G722 and 1-way audio - even to voicemail

core
configuration
Tags: #<Tag:0x00007f749b2f0780> #<Tag:0x00007f749b2f04d8>

(Rob Thomas) #41

This is what I keep saying - it works for me. My normal desk phones are selection of SPAs and a Digium D70. They all work fine.


(Andrew Nagy) #42

I just took my desktop T38 and forced g722 on a PJSIP extension. Dialed *43 and it worked fine. I can post the video if someone really needs me to do so.


(Rob Thomas) #43

Can you please factory reset those phones, and do not do anything else apart from setting the username, password, and server? Don’t provision them, don’t do anything. Just log into the GUI, enter those three things, and then try *43.


(Andy) #44

So, hello everyone!

I have got the same issues here. I upgraded my FreePBX Distro to V13 with Asterisk 13.5 - all updates are installed.
In the past, I was using chan_sip to connect to my endpoints and trunks and everything was fine. For testing purposes, I changed some extensions to use pjsip. And that’s when all got odd. It’s the same as described here. Internal calls between to pjsip extensions using G722 work just fine - but when it gets to playback of internal audio files like announcements, there is just silence. I’ve tested with different extensions and different endpoints. My Yealink T38G, my Grandstream GXV3175v2 and my Siemens Gigaset VoIP DECT Phone. All the same. All have worked properly with chan_sip, but they don’t do with chan_pjsip - as long as you use G722 as voice codec. Only my Aastra 6755i seemed working as it should.

I then figured out a mysterious behavior: In the phone configs, I had set the phones to may use multiple voice codecs. G722, alaw and gsm (as I live in Germany), while the G722 codec came in the first place, as ist should be prefered. I removed all codecs except the G722 in the phone configuration. Believe it or not, that did it. All phones now were playing the audio files.

Of course this is not a solution, because I still want the phones to be able to use a branch of codecs, as they did, when using chan_sip. For me, there are still issues, that make me return to chan_sip. That’s because, my trunks use chan_sip with alaw as codec, and with pjsip endpoints external calls only ring 10 seconds and then break down - but are displayed and handled as answered. I think, this might also have something to do with the codec or the transcoding.

So, if you ask me: I don’t think we have an FreePBX related issue here. It also isn’t phone related, because ist happens on multiple endpoints. In deed, only my Aastra Phones seem to have no problems even when multiple codecs are selected. What we have here seems to be a problem with the chan_pjsip driver.

Oh, by the way: I followed your tip, Rob. Factory reset and just registering the phones didn’t change anything.

Perhaps my “encounters” help to solve the problem.

Kind regards from Germany
Andy


(Andrew Nagy) #45

As previously stated it just needs to be reported to the Asterisk bug tracker.


(Lorne Gaetz) #46

Ran into this issue today. 3 of my 4 endpoints would only get silence when playing g722 system recordings. At some point it magically started working and have been unable to recreate. As far as I can tell, the only thing I did that might have fixed was:

fwconsole restart

(Rob Thomas) #47

Woo, Lorne was able to duplicate it! likes post

3 of 4? Odd…

‘Magically?’… uhoh…

ARGH!


(Marcelo) #48

Were you being sarcastic on your last post? Sorry, I am really in doubt.

I can give access to my FreePBX box that has this problem. If anyone wants to log in and take a look, be my guest. What I need is the IP address of the person loggin in and the public ssh key (contents of the .ssh/id_rsa.pub file).

I can open ports 22/tcp, 5060/udp and 10000-20000/udp, temporarily and only to the IP address informed.


By the way, the problem happens for me both on Yealink and on Grandstream phones (I only tested these 2 brands).

Best regards,

Marcelo


(Andrew Nagy) #49

No. This issue needs to be brought up to Asterisk. There’s nothing FreePBX can do.


(Marcelo) #50

Well, maybe someone from FreePBX side would be interested in digging a bit, even if to get it fixed on Asterisk? If some Asterisk expert can take a look at it and open a ticket it will have better chances of being worked on.

If I go to Asterisk community and say I have a one-way audio problem with G722 they will call me crazy just like happened here :smile:


(Andrew Nagy) #51

We have. We can’t replicate it.

That is not true. All tickets have the same priority.


#52

Ive had a similar issue.
See en_GB Sound Language Pack Not Working

To summaries: -

I installed the FreePBX-64bit-10.13.66.iso distribution.
We have Yealink T23G handsets. By default G722 is enabled.

Using the default sound pack (English) with G722 enabled it works fine.

If you swap the sound pack on FreePBX to English United Kingdom, you get silence if the handset is using G722.

If you disable G722 on the handset English United Kingdom sound pack works.

This is repeatable.

I would like to use G722. Is there a fix pending ?


(Andrew Nagy) #53

There is no fix. You need to bring this up with asterksk/digium. It’s not a freepbx issue.


(Jeremy) #54

I know Andrew and Rob both were able to get this to work. But I am curious, in your testing, did you:

  1. Go to Settings —> Asterisk SIP Settings and enable the g722 codec and make it the top priority?
  2. Or did you go to the extension settings page, enter “all” in “Disallowed Codecs”, and enter “g722” in “Allowed Codecs”?

If you tested with method 2, it will work every time. 2 way audio with the PBX will work without any issue using the g722 codec. But, if you use method 1, it has failed for me every time in my testing. Thus, it seems possible that this is a FreePBX issue, not an Asterisk issue. Asterisk is obviously able to transcode properly, because method 2 above works fine.


(Andrew Nagy) #55

If you can prove that it’s a configuration issue we are all willing to fix it (Obviously). But we can’t duplicate and if we can’t duplicate then we can’t be expected to fix it (because how would we know what to do).

Please stop pointing the blame on FreePBX unless you can prove (through configurations) that it is the problem. Otherwise we keep going in circles.


(Jeremy) #56

Andrew - Read my post again. In fact, let me quote, italicize and place in bold the part you missed:

No need to be a jerk. I’m not pointing blame at FreePBX. I’m trying to figure it out, along with the other 6 people in this thread that have experienced the same problem. Because you can’t duplicate it, you are the one insisting it is an Asterisk issue. In fact, I had dropped the issue due to your confrontational nature in participating in this thread. But, as additional users continue to experience the problem, it pops back up on my radar and I look into it a little further.

Now that we have addressed that, you still didn’t answer my question in my last post. Let me remind you:

I’m not sure how you tested, but if you watch Rob’s video here, you will see that he tested using method #2 from my post:

Myself and others have confirmed that it works fine if forcing the g722 codec from the extensions page. However, since you haven’t answered the question, you have not proved that you duplicated the scenario I proposed as Method #1.

Please forgive me for using the Open Source FreePBX Distro and using it’s community forum for seeking help with a problem I experienced using… the FreePBX Distro. In fact, the whole nature the community exploded right after we purchased some Commercial Modules. The whole FreePBX/Sangoma vs Ward Mundy debate started, and the Sangoma Community Forum became much more confrontational and condescending. Let’s just say that it didn’t take long for me to start questioning the wisdom of where we spent our money.

Since I am not a developer, I obviously do not approach such matters the same as you would. I simply don’t have the experience or focused expertise you possess as a developer. But, my troubleshooting skills have shown me that Asterisk can transcode properly. (See Rob’s video.) But, by configuring Asterisk, using FreePBX, with two different approaches to using the g722 codec, you get different results. In my simple mind, these results don’t isolate FreePBX or Asterisk as the source of the problem. I apologize that I have used the Sangoma/FreePBX “Community Forums” for discussion, rather than strict issue reporting.

Would it be possible to get a straight answer about your approach to testing this issue? Did you force the g722 codec on the extension page? If so, you, myself and others (including Rob in his video) confirm it works, just as you insist. However, there are about 6 people (excluding any Sangoma/FreePBX developers or support staff) that have experienced this problem while configuring FreePBX by going to the ‘Settings -----> Asterisk SIP Settings’ in FreePBX, enabling the g722 codec, then making it the top priority. Using this method of configuration, we (at least 6 FreePBX users) experience one way audio.

I hope you are able to understand my frustration with the confrontational reply I received and are able to simply answer my question, rather than accuse me of any ill intent.


(Andrew Nagy) #57

I am not being a jerk

I’m also not being confrontational

Never once accused you of any ill intent.


(Jeremy) #58

Thanks for answering my question.


(Andrew Nagy) #59

I am sad that you think this has anything to do with me and how I deal with responses and tickets. In fact this is the only thread I have participated in with you. Being a jerk can go both ways. I think you will agree looking back at this thread.


(Andrew Nagy) #60

Did it. Worked fine.