FPBX13 RC, G722 and 1-way audio - even to voicemail

Ran into this issue today. 3 of my 4 endpoints would only get silence when playing g722 system recordings. At some point it magically started working and have been unable to recreate. As far as I can tell, the only thing I did that might have fixed was:

fwconsole restart
1 Like

Woo, Lorne was able to duplicate it! likes post

3 of 4? Odd…

‘Magically?’… uhoh…

ARGH!

Were you being sarcastic on your last post? Sorry, I am really in doubt.

I can give access to my FreePBX box that has this problem. If anyone wants to log in and take a look, be my guest. What I need is the IP address of the person loggin in and the public ssh key (contents of the .ssh/id_rsa.pub file).

I can open ports 22/tcp, 5060/udp and 10000-20000/udp, temporarily and only to the IP address informed.


By the way, the problem happens for me both on Yealink and on Grandstream phones (I only tested these 2 brands).

Best regards,

Marcelo

No. This issue needs to be brought up to Asterisk. There’s nothing FreePBX can do.

Well, maybe someone from FreePBX side would be interested in digging a bit, even if to get it fixed on Asterisk? If some Asterisk expert can take a look at it and open a ticket it will have better chances of being worked on.

If I go to Asterisk community and say I have a one-way audio problem with G722 they will call me crazy just like happened here :smile:

We have. We can’t replicate it.

That is not true. All tickets have the same priority.

Ive had a similar issue.
See en_GB Sound Language Pack Not Working

To summaries: -

I installed the FreePBX-64bit-10.13.66.iso distribution.
We have Yealink T23G handsets. By default G722 is enabled.

Using the default sound pack (English) with G722 enabled it works fine.

If you swap the sound pack on FreePBX to English United Kingdom, you get silence if the handset is using G722.

If you disable G722 on the handset English United Kingdom sound pack works.

This is repeatable.

I would like to use G722. Is there a fix pending ?

There is no fix. You need to bring this up with asterksk/digium. It’s not a freepbx issue.

I know Andrew and Rob both were able to get this to work. But I am curious, in your testing, did you:

  1. Go to Settings —> Asterisk SIP Settings and enable the g722 codec and make it the top priority?
  2. Or did you go to the extension settings page, enter “all” in “Disallowed Codecs”, and enter “g722” in “Allowed Codecs”?

If you tested with method 2, it will work every time. 2 way audio with the PBX will work without any issue using the g722 codec. But, if you use method 1, it has failed for me every time in my testing. Thus, it seems possible that this is a FreePBX issue, not an Asterisk issue. Asterisk is obviously able to transcode properly, because method 2 above works fine.

1 Like

If you can prove that it’s a configuration issue we are all willing to fix it (Obviously). But we can’t duplicate and if we can’t duplicate then we can’t be expected to fix it (because how would we know what to do).

Please stop pointing the blame on FreePBX unless you can prove (through configurations) that it is the problem. Otherwise we keep going in circles.

Andrew - Read my post again. In fact, let me quote, italicize and place in bold the part you missed:

No need to be a jerk. I’m not pointing blame at FreePBX. I’m trying to figure it out, along with the other 6 people in this thread that have experienced the same problem. Because you can’t duplicate it, you are the one insisting it is an Asterisk issue. In fact, I had dropped the issue due to your confrontational nature in participating in this thread. But, as additional users continue to experience the problem, it pops back up on my radar and I look into it a little further.

Now that we have addressed that, you still didn’t answer my question in my last post. Let me remind you:

I’m not sure how you tested, but if you watch Rob’s video here, you will see that he tested using method #2 from my post:

Myself and others have confirmed that it works fine if forcing the g722 codec from the extensions page. However, since you haven’t answered the question, you have not proved that you duplicated the scenario I proposed as Method #1.

Please forgive me for using the Open Source FreePBX Distro and using it’s community forum for seeking help with a problem I experienced using… the FreePBX Distro. In fact, the whole nature the community exploded right after we purchased some Commercial Modules. The whole FreePBX/Sangoma vs Ward Mundy debate started, and the Sangoma Community Forum became much more confrontational and condescending. Let’s just say that it didn’t take long for me to start questioning the wisdom of where we spent our money.

Since I am not a developer, I obviously do not approach such matters the same as you would. I simply don’t have the experience or focused expertise you possess as a developer. But, my troubleshooting skills have shown me that Asterisk can transcode properly. (See Rob’s video.) But, by configuring Asterisk, using FreePBX, with two different approaches to using the g722 codec, you get different results. In my simple mind, these results don’t isolate FreePBX or Asterisk as the source of the problem. I apologize that I have used the Sangoma/FreePBX “Community Forums” for discussion, rather than strict issue reporting.

Would it be possible to get a straight answer about your approach to testing this issue? Did you force the g722 codec on the extension page? If so, you, myself and others (including Rob in his video) confirm it works, just as you insist. However, there are about 6 people (excluding any Sangoma/FreePBX developers or support staff) that have experienced this problem while configuring FreePBX by going to the ‘Settings -----> Asterisk SIP Settings’ in FreePBX, enabling the g722 codec, then making it the top priority. Using this method of configuration, we (at least 6 FreePBX users) experience one way audio.

I hope you are able to understand my frustration with the confrontational reply I received and are able to simply answer my question, rather than accuse me of any ill intent.

I am not being a jerk

I’m also not being confrontational

Never once accused you of any ill intent.

Thanks for answering my question.

I am sad that you think this has anything to do with me and how I deal with responses and tickets. In fact this is the only thread I have participated in with you. Being a jerk can go both ways. I think you will agree looking back at this thread.

Did it. Worked fine.

Sure. I did it both ways you described and didn’t have an issue. Which is why I didn’t say anything (actually I was trying and @lgaetz was trying and @xrobau this morning. Before your next reply). I stand by my statement. In fact this isn’t an Asterisk issue at all, nor is it a FreePBX issue.

[quote=“Bullfrog, post:56, topic:31042”]
In fact, the whole nature the community exploded right after we purchased some Commercial Modules.[/quote]

I would just like to point out that it has no relevance if you have, or have not, purchased modules, and I don’t like the insinuation. I am even hesitant to recommend people to use commercial support in IRC, because I believe I’m abusing my status by doing so. I’m just going to take it as you saying ‘I’m doing my best to support the project’, and I appreciate that, but I tend to get a bit fidgetty about peoples passive aggressive, backhanded accusations, ESPECIALLY when you say this next:

There is no ‘FreePBX/Sangoma vs Ward Mundy’ debate. There is just Ward Mundy doing his best to abuse, discredit, and disrupt the FreePBX project. He has taken this so far that one of our developers had to create a new facebook account, and he’s publically posted other developers personal information - in fact, just the day before yesterday, he linked to @drmessano’s Google plus page, because … I don’t know why. And it’s not like drmessano is a developer, he’s just someone who knows how freepbx works, and offers free support in IRC.

I honestly have no idea what Ward’s trying to achieve by destroying the project that he bases HIS project on, and it appears amazingly counter-intuitive to do so. However, this is open source software, and if he wants to try to destroy it, then that’s his choice.

I ignore what Ward says, I ignore his tweets. I don’t block him on Twitter because I don’t think it’s fair that he would need to log out to see what (FreePBX-related) stuff I tweet about. We write open source code .We give it away. We care.

We, honestly, try to be the good guys. Quite a few times I’ve actively asked the rest of the guys ‘Are we wrong? Are we NOT being the good guys?’. Being yelled at for doing stuff wrong is awesome. Because then we KNOW we’re doing stuff wrong. But being yelled at for NOT doing stuff wrong, or even worse, being yelled at because he fundamentally doesn’t understand how FreePBX works, is emotionally draining.

So, I apologise for that rant, but that’s how I see things from my perspective. When he says ‘Module signing isn’t open source’, for example, and he is fundamentally wrong about that, and refuses to admit it, what can I do? It’s open source. It’s documented. He can do exactly what we do, with the tools we provide. Yet he claims he can’t.

This probably should have been ripped out into a different thread, but @tm1000 (who is literally sitting across the table from me at the moment) just grabbed me and said ‘More G722 issues’ and this was the first thing I saw.

On the downside, he’s literally just followed the instructions he gave, and didn’t have the problem. Even with the en_gb prompts.

@lgaetz (sitting next to @tm1000) suggests that it may be phone related, which sounds much more reasonable. That was the first thing I suggested, way up at the start of this thread. Try it with a different device .If it works with a different device, then it’s the device, or, asterisk.

Edit: Proof of @tm1000 actively trying to duplicate this:

Either way, it’s not a FreePBX issue. All FreePBX does is write the configuration files. Asterisk is what actually does the transcoding. We’re not trying to dodge the problem, we’re just saying that we can’t duplicate it. If we can’t duplicate it, we can’t fix it.

Thank you for the reply. I appreciate that you have confirmed you duplicated the scenario as best you could without the same result

To address the balance of this unfortunate turn of events:

@tm1000 - I was simply noting your quick confrontational reply where you attempted to argue that you weren’t being confrontational, without answering my simple question about your method of configuring the test in FreePBX. The irony was pretty awesome. Of course, your edits to your reply to me and your edits to my reply to you erased most of the evidence.

It is obviously pretty difficult to disagree with you on your own turf… especially when you have the power to remove the evidence from your reply and my quote of your reply. (I realize anyone can read the edits, but really, who is going to do that?) I can’t remove my words from your posts where you quoted me. Therefore, I’ll leave my comments in place.

I’m sorry I overreacted to your short response to my post. I was simply seeking clarification to the testing method you used. A simple confirmation would have been sufficient.

[quote=“xrobau, post:62, topic:31042, full:true”]

@xrobau - I agree with most of what you said. The community has obviously been able to observe the developments and draw their own conclusions. Many times I have read his words and recognized that he had gone too far. There is a very loyal community on his site and it contains a wealth of information that can benefit a person learning or troubleshooting Asterisk and FreePBX. However, the constant attacks are detracting from that reputation.

I have to commend Sangoma and the FreePBX team. Despite the attacks, Sangoma and the FreePBX team have not replied in kind. (Of course, I have no idea what has been said privately.) By refusing to retaliate publicly, the Sangoma and FreePBX reputation has been strengthened.

So, I apologize that my comments indicated there was a ‘FreePBX/Sangoma vs Ward Mundy debate’. It really has been one-sided. I intended to draw attention to the fact that things have changed over the last several months. Some good, some frustrating. I hope this all passes and is quickly forgotten. But, I also hope that the FreePBX team can appreciate they have millions of loyal users, and if we are made to feel as if we can’t discuss, troubleshoot, and ask questions, the support will begin to erode.

1 Like

@xrobau and @lgaetz:

Thanks for giving some meaningful feedback. It was very helpful. I was able to get my hands on an Aastra 6737i to test with. As you suggested, it worked fine. So, that leads to the fact that we know it doesn’t work on many Yealink models as reported in this thread. Also, there are these reports:

I’m not sure which 3 endpoints @lgaetz was using, but the problem has been experienced on Yealink, Grandstream, Linksys/Cisco, and Siemens. On the other hand, Aastra devices work fine. Is it possible this is a problem that affects many brands and devices?

@tm100 - That is a little different, you previously insisted this should be reported to Digium/Asterisk. Were you able to identify the problem? I would be interested to know what led you this new conclusion.

1 Like