Fpbx problems after upgrade to 14

Hi, Was hoping someone could help. my system is currently stuck after a Framework upgrade to V14. Module Admin shows “Disabled; Pending Upgrade to” and Apply Config gives the following errors:

exit: 1
Unable to continue. The process has been signaled with signal “7”. in /var/www/html/admin/modules/recording_report/vendor/symfony/process/Process.php on line 434 #0 /var/www/html/admin/modules/recording_report/vendor/symfony/process/Process.php(212): Symfony\Component\Process\Process->wait() #1 /var/www/html/admin/libraries/media/Media/Driver/Drivers/FfmpegShell.php(46): Symfony\Component\Process\Process->run() #2 /var/www/html/admin/libraries/media/Media/Media.php(126): Media\Driver\Drivers\FfmpegShell::installed() #3 /var/www/html/admin/libraries/BMO/Media.class.php(80): Media\Media::getSupportedFormats() #4 /var/www/html/admin/libraries/BMO/Media.class.php(40): FreePBX\Media->getSupportedFormats() #5 /var/lib/asterisk/bin/retrieve_conf(77): FreePBX\Media->getSupportedHTML5Formats() #6 {main}

1 error(s) occurred, you should view the notification log on the dashboard or main screen to check for more details.

I´ve tried upgrading via CLI with

  • fwconsole ma upgrade framework

This returns

- No repos specified, using: [standard] from last GUI settings

framework is the same as the online version, unable to upgrade
Updating Hooks…Done


fwconsole reload

This returns the following errors

Reloading FreePBX
Error(s) have occured, the following is the retrieve_conf output:
exit: 1
Unable to continue. The process has been signaled with signal “7”. in /var/www/h tml/admin/modules/recording_report/vendor/symfony/process/Process.php on line 43 4
#0 /var/www/html/admin/modules/recording_report/vendor/symfony/process/Process.p hp(212): Symfony\Component\Process\Process->wait()
#1 /var/www/html/admin/libraries/media/Media/Driver/Drivers/FfmpegShell.php(46): Symfony\Component\Process\Process->run()
#2 /var/www/html/admin/libraries/media/Media/Media.php(126): Media\Driver\Driver s\FfmpegShell::installed()
#3 /var/www/html/admin/libraries/BMO/Media.class.php(80): Media\Media::getSuppor tedFormats()
#4 /var/www/html/admin/libraries/BMO/Media.class.php(40): FreePBX\Media->getSupp ortedFormats()
#5 /var/lib/asterisk/bin/retrieve_conf(77): FreePBX\Media->getSupportedHTML5Form ats()
#6 {main}

Phones are still working but GUI is all over the place.

All other standard modules are working and updated as they should be except Framework which is disabled pending upgrade.

Thank you in advance for any assistance someone can provide.


Assuming you are using the method on this page, have you run the repair script?

Hi lgaetz, no I havent tried that, I will try that next and letyou know. Many thanks for your response.

Hi lgaetz, I tried that and it appears to have broke everything, cant make calls now either. Would really appreciate a next step. Thank you in advance.

There’s nothing anyone can do based on that description other than advise you to restore the 13 system from backup.

Ok thanks anyway

Update - it appears there is a hardware fault and the update only highlited the problem. There is a bad sector on the hard drive, aterisk db is corrupt but calls are still processing at the moment.

Update to V14 was unrelated to the actual issue.

Many thanks anyway.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.