FPBX not recording calls

I have established a PJSIP extension and activated recording of calls within voicemail. I have called the extension externally and internally and said a few words. I visit CDR reports and find that the call is noted however it has not been recorded.
Is there a setting that I have messed up??

Are your “few words” long enough to be above the “minsecs” limit you probably have in your voicemail.conf file?

All voice messages left would be between 5 and 10 seconds perhaps longer


So all of your calls longer than 4 seconds by default would make it to disk.

Thanks for your response dicko. I will continue to experiment to determine the problem even to the point of reinstalling FPBX

Unless you did something extra-ordinary as you installed, a re-install would be pointless. Just start with reading a whole stanza of a poem to voicemail, also make sure recording an active call also works, (voicemail kinda just works for everybody else)

Any voice message does in fact appear on the Yealink phone (message light is on) and I have access to it via *97 and I can listen to it. Its just that it doesn’t appear in CDR Reports. Maybe I am accessing CDR Reports incorrectly but I cant see how as its pretty simple.

To listen to voicemails you can as you have discovered use *97 ( and *98), they would not however be apparent as ‘downloadable media’ in the cdr reports (whereby otherwise ‘recorded’ calls would be) , but they would , more appropriately, be available in the users UCP

I am not having a good day!!..I have established a new extension. Rang in from external line. Left a message. Go into UCP using the extension number (500) as user name and password copied and pasted from uer password in the user manage settings. Result “invalid login credentials”.
Do I need to select some setting to allow access to UCP

There is a wiki link available at the top of this page, did you ever go there? A whole bunch of stuff there

No…but I will go there now and check it out…Thanks

As with anything , if you don’t RTFM you get to pay extra when you “ass’u’me”

Get your ducks in a row first :slight_smile:

Easy when you know where to find the ducks…:roll_eyes:

You found them already, if you use ucp then both the server and the client must agree, sorry, but back to RTFM’ing

Into the UCP now. All this started with the call recording problem which still remains a problem but I am sure I will figure it out with the help of Wiki

Please separate any ptoblems you have with voicemail from other recording issues, they are chalk and cheese.

Will do…thanks :slight_smile:

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.