FPBX Distro 14->15 upgrade failed due to curl timeout


(Matt Hettermann) #1

Working FPBX 14 distro, fully updated. Module updates worked, system updates worked, yum worked, ping mirror1 and mirror2.freepbx.org worked, with good ping times (~50ms). AT&T Gigabit Fiber internet.

Tried to upgrade via 14->15 upgrade module a few times over 48 hours (Thu/Fri this week) - would always fail the precheck with a curl timeout.

Seemed to be similar to what is described in FREEPBX-20726 (https://issues.freepbx.org/browse/FREEPBX-20726). I changed the following line in Versionupgrade.class.php:

$this->freepbx->Curl->addOption(‘timeout’, 30);

to

$this->freepbx->Curl->addOption(‘timeout’, 90);

And the upgrade precheck ran successfully, and then the upgrade went on to complete fine.

Sharing here in case anyone else gets bitten by this issue …


(TheWebMachine Networks (Sangoma Software Development Partner)) #2

Your issues were likely due to some intermittence in the availability of the FreePBX repo mirrors. They were bouncing on/offline and lagging quite a bit over the weekend partly due to high demand placed upon them. The reason increasing that timeout worked for you is because the repos were lagged more than they were offline…resulting in response times that could easily exceed 30s.

You will also want to check and confirm you aren’t still using the legacy Repo mirror1 as your default via SSH:

  1. fwconsole setting MODULE_REPO
    If you see mirror.freepbx.org as the first in the list, you’re good:
Setting of "MODULE_REPO" is (text)[https://mirror.freepbx.org,http://mirror1.freepbx.org]
  1. If you see mirror1 first and/or you see mirror2 AT ALL, you need to update your list:
    fwconsole setting MODULE_REPO https://mirror.freepbx.org,http://mirror1.freepbx.org

Mind you, even mirror.freepbx.org was bogged down this weekend, so the 30s timeout was likely still not enough (we get alerted when lag exceeds 25s and got a few alerts)…Sangoma should probably make the default timeout 90s instead of 30s until the day comes when their repo mirrors can handle their popularity a bit better. :man_shrugging:


(system) closed #3

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.