Fpbx 2.804 can't get e-mail backup to send backup file

I started with asteriskNOW 1.7.1 and updated centos using yum, and updated asterisk to 1.8.2.2.
when I try to use backup now, I have the file on the asterisk server, but nothing shows up in e-mail. I am new to this, so what am I missing?
a test message from mail worked, are there more setup steps that weren’t done in the asterisknow setup?

If you feel comfortable editing php files then you should continue. If you have ANY hesitations DO NOT try the following.

As always backup your files before you start editing them.

Now that that is out of the way…I ran into the same problem and here is what I did to resolve it.

  1. You should add an alias email address to the asterisk account on the box. (/etc/aliases) add the following line replacing the email address with your own. You should also do the same for root if you don’t check email that gets sent to the local machine(cron errors and other notifications)

root: [email protected]
asterisk: [email protected]

  1. Once done reload aliases from root.

[[email protected] ~]# newaliases

  1. Trigger the backup to run. You should now get a response (to [email protected]) from your cron detailing the errors. (since now you receive errors that are a result of asterisk account triggered events)

  2. First error is…

PHP Notice: Undefined index: AMPBACKUPEMAILFROM in /var/www/html/admin/modules/backup/bin/ampbackup.php on line 206

This indicated that it couldn’t pull the string $amp_conf[‘AMPBACKUPEMAILFROM’]

So quite simply I replaced “.$amp_conf[‘AMPBACKUPEMAILFROM’]” with "[email protected]" (please replace pbx.domain.com with the FQDN for the box). When I have time I’ll probably trace the error back and find out why, but for now this method works. Make sure to put single quotes around the email address that you type here.

  1. I reran the backup and only one error came back. It was…

PHP Fatal error: Allowed memory size of 104857600 bytes exhausted (tried to allocate 40598941 bytes) in /var/www/html/admin/modules/backup/bin/ampbackup.php on line 225

This error indicates thatthe memory_limit is too small to encode your data prior to emailing. You can adjust the memory limit in the ampbackup.php file by adding a line before the base64_encode function on or about line 226 of the file. I added the following.

ini_set(“memory_limit”,“1000M”);

You’ll obviously need sufficient memory to run this. If you don’t have sufficient memory, don’t increase it. You’ll run into additional errors. (FYI…I have 2GB in this machine)

Let me know if you have any luck.

Regards,
Steve

looking at the install.log under root, I get a long list of ‘warning: user asterisk does not exist - using root’ alternating with ‘warning group asterisk does not exist -using root’