FPBX 14, CDR Reports timezone again

Hello, i have such setup:
Centos 7 + FreePBX14( + CDR Reports(
No System Admin module cause its manual installation on VDS.

In Advanced Settings->PHP Timezone->America/Phoenix
In TimeConditions -> showed correct time
In linux /etc/localtime also America/Phoenix
Asterisk date same correct America/Phonex
In /etc/asterisk/cdr_adaptive_odbc.conf usegmtime=yes
In mysql correct gmt time.
But in CDR reports showed -1 hour from America/Phoenix timezone.

Any suggestion ?

Set the system clock to your desired time zone.

system clock is correct. linux date shows correct time in timezone ‘America/Phoenix’.

vds1005x11:/usr/src/asterisk-14.7.8/configs/samples# date
Thu Oct 11 05:00:57 MST 2018

So any call that would happen right now the CDR’s would show it as 4:01 AM (example) instead of 5:01AM?

yes, exactly

Set the time information on the user you are using to login to the GUI.

i use default admin for it, but have no idea how i can change time for that user,cause have no AdminModule( i use FreePBX on Centos7\VPS not FreePBXDistro)

UPD. Via “User Management” i get extension user and give him right to access FreePBX admin, also change timezone to Phoenix for him

 fwconsole r 
service httpd restart
  • same result, time less on 1 hour showed

UPD i use such workaround: disable gmt in cdr_adaptive_odbc.conf, and set UTC+1(London) for user with access to CDR only via User Managment.

Arizona doesn’t do Daylight Saving Time and the rest of Mountain Time does…

Right, the Time Zone is correct. When the OP posted their current time/date from their system the other day to show the Time Zone:

It was 8AM EST for me, that makes Mountain 2 hours behind me unless they aren’t following DST which means them 3 hours behind me. They have the right Time Zone set.

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.