Foward call issue

Currently our phone system routes all of our incoming calls on our main line to a ring group that goes to our answering service during the business hours of 8:30am – 5:00pm. It works great as long as their staff is able to pick up the calls during this time frame. However once in a while they do not pick up a call and it goes into our voicemail box in the answering services office phone system.

They say that they do not have any way of notifying us when a message has been left there. I find this hard to believe that their 1 year old Mitel phone system does not have unified messaging, however I am stuck and have to call in several times daily to check voicemail that is rarely left there.

Is there any way that FreePBX can route the call to an IVR before it goes to their voicemail?

It may annoy your answering service, but you can enable “confirm calls” in the ring group which will force them to press one to answer, that way their VM will never catch the call.

Or have them program their Mitel “Call Rerouting first alternative” to default (1), i.e. no voicemail for your DN. (Directory Number), better yet to reroute to your preferred backup number.

Confirm Calls… Yes I can see where that would annoy them. I would prefer not using that feature unless there is no other alternatives.

I have tried to get them to do something on their end to no avail. That is why I am trying to resolve it on my end. As you suggested I would prefer that they reroute to my backup number.

If I can get them to remove my voicemail will my system send it to the destination that I choosen under the Ring Group setting under “Destination if no answer”?

What about shorting the “Ring Time” setting in the Ring Group?


Thanks for your replies! After a discussion with the office manager I have forwarded the Mitel information along and they are going to talk to their phone vendor.