Force Outbound Route


(Kirk Bocek) #1

I’m trying to setup a dial prefix to force dialing on a specific trunk.
I’ve created an outbound route and selected the desired trunk. I’ve put 999 in the prefix box. I’ve tried several match patterns. It seems like X. should match everything.

This issue is that when dialing my 999 number. The system rings once and hangs up.

Any thoughts?


(Andrew) #2

Post call logs to pastebin and link it here.


(Sholinaty) #3

prefix: [ 999 ]
Match pattern [ XXXXXXXXXX ] for north american 10-digit dialing
or NXXNXXXXXX

if you want to catch “All” 999- codes (DONT DO THIS, 999 is an emergency dialing code in some areas!!), you want:
prefix: [999]
match pattern [ . ]


(Sholinaty) #4

and dont forget to move this new outbound route ABOVE your other routes, as i believe the outbound route list is processed top down for priority.


(Lorne Gaetz) #5

It is. Most specific rules first starting with emergency dialing, proceeding down to the most general at the bottom.


(Sholinaty) #6

it is

sorry @lgaetz - “affirmative, top down”? or “its most specific to least”?
(i think im mis-reading your comment)


(Lorne Gaetz) #7

I was confirming that you are correct. Outbound routes are processed from the top down, so a generic catch all dial pattern on the first outbound route will ensure that nothing else is used below.


(Kirk Bocek) #8

I tried 999 and . Same thing, system kinda does a half ring and hangs up my call.


(Kirk Bocek) #9

So I checked the call log.
2021-10-01 12:58:39 [1633118318.66](http://raspbx.pvt/admin/config.php?display=cdr&action=cel_show&uid=1633118318.66) "Kirk's Office" <10> <92529347xx> Dial 99998033XX ANSWERED 00:04

The outbound CID is correct. Should the destination number have the 999 stripped out?


(Kirk Bocek) #10

So looking at the call logs, I see one issue was using 999 as the prefix. I changed it to 123 and the call log was shorter. Only 7 entries. However the call still did not go through. Also, I see mention of both trunks even though my 123 rule is earlier and does not reference the other trunk.


(Lorne Gaetz) #11

Still waiting for a call trace via pastebin. Enable noop traces to 3+ in advance settings first. It will log which route is used

https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


(Kirk Bocek) #12

So that page says to extract the call ID from the GUI then grep /var/log/asterisk/full for it. But there are no results. Where is the call information?

=====

So I tried setting debug and verbose to 3. Calls are still not being logged to full.


(Andrew) #13

/var/log/asterisk/full is only the most recent log file. It rotates, so if the call took place yesterday you need to look in the prior file.

ls -al /var/log/asterisk | grep full

(Kirk Bocek) #14

Nope. I was grepping for a call I just made. When I ‘tail -f’ the log file I do not see any entries made when I place a call.


(Itzik) #15

What is the full tail -f arguments that you used?


(Kirk Bocek) #16

I need some help getting FreePBX to log calls to /var/log/asterisk/full. Right now it is not doing that. As I said above I played with both the debug setting and the verbose setting. Still nothing.The “Great Logs” page provided above does not discuss this issue.


#17

From a shell, post the output of :-

rasterisk -x 'logger show  channels'

(Kirk Bocek) #18
Logger queue limit: 1000

Channel                             Type     Status    Configuration
-------                             ----     ------    -------------
/var/log/asterisk/full              File     Enabled    - WARNING ERROR VERBOSE DTMF
                                    Console  Enabled    - WARNING ERROR DTMF

#19

It is ‘verbosely’ logging to the file but not to the console, set the categories and the verbosity in the “settings -> log files -> logfiles” page


(Kirk Bocek) #20

A little more detail please. The ‘full’ log is already set to Verbose 5. I set the console verbose to 5. Still no logging. What do you mean by ‘categories’?