FOP2 resets queue historical data when reloading the browser page

Hello community!

We have FOP2 on FreePBX 14 Asterisk 14. I’m wondering how to troubleshoot the following:

We have a few users logged into FOP2, Queue Stats is set to reset every day at 23:59 which works fine, but when someone is refreshing the browser page or logging in to FOP2 in the middle of the day it starts a new call count for that user.
So every user has different Queue Statistics information… which causes a bit of mess for the managers to keep track of the Queues.

I would appreciate if anyone can try to reproduce this, might be a bug? (note: we have a few FOP2 servers on FreePBX 13/Asterisk 13 and it holds the data every time you refresh or login mid day)
Or if anyone can provide some tips how to troubleshoot this.


On the one hand, I’m sure someone here that uses FOP2 will probably be interested in comparing notes, but remember that FOP2 (like many other popular additions) isn’t really part of FreePBX. Have you asked your question at the FOP2 site as well?

Unfortunately we’re waiting for their support almost for two weeks to get back to us.
We had once that they responded by chat and troubleshooted a server with us, when they respond they are fine… which is why i figured to ask my next question regarding FOP2 here, where i believe there’s someone with the same version(s) that can try to reproduce this.

That’s not an uncommon problem with many of these Open Source/Commercialized OSS systems.

A quick troubleshooting question would be “does the count start at zero when you bring up the browser for the first time?” If so, the number would seem to be unreliable from the start.

I monitored the calls, it counts correctly talk time, abandoned calls, answered calls, hold time etc. But upon refreshing it starts from 0 again.

OK - so if you start the browser halfway through the calling day, does the browser pull the stats correctly for the entire day, or just from the time you started.

if the latter, it’s possible that this is a design flaw (or at least, implementation flaw) that isn’t going to solved in a simple way.

As mentioned in the first post, it starts a fresh count. (Let’s say there’s about 100 Calls per hour, User-1 logges in when the days starts, 3 hours later User-2 logs in, when we are at the 4th hour, User-1 will have 400 calls while User-2 will only have 100 calls)

The fop2 forum pretty much went dead some time ago.
It was not really a community forum, but more or less a place where the developer provided free support.
People were asking questions and he answered them.
He even helped fix an issue on my server remotely one time for free. Paid support and his knowledge of Asterisk are outstanding.

My guess is that that one man show wasn’t sustainable and he wanted to bring the fop2 forum into more of a community driven place like this one is.
That doesn’t work though, because there aren’t any people who know much about fop2.
Maybe we will someday, cause I prefer it a lot over isymphony and would like it to stay around and for it to be discussed here more.

I am running fop2 on Freepbx high availability clusters.

Fop2 is also integrated into the new open source Asterisk project “issabel”, so you might be lucky on their forum.

1 Like

Thank you for responding.

However, before doing some deep troubleshooting, i would first like to hear from anyone that tried to reproduce this on FreePBX 14/Asterisk 14. Might be FOP2 its an issue with the PBX/Asterisk version. (I’m not trying to point fingers…)

Hello @PitzKey,

Do you use the FOP2 wallboard module?
Did you try to downgrade your asterisk version to 13?

If you do not want to reset the queue stats you can use this command (in the Asterisk console):
config reload /etc/asterisk/queues.conf

Ask from Nicholas to integrate this command in the module.

Thank you,

Daniel Friedman
Trixton LTD.

Thanks for your response.


I’m not certain that this is a Asterisk 14 issue, so far no one here replied that they have the same issue on Asterisk 14.


Update… asternic call center stats pro was somehow missing.
Works fine after installing.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.