FOP2 Clients Fail to Connect

I’ve had Flash Operator Panel 2 working fine for years against my FreePBX All of a sudden just today my web clients aren’t connecting. They see the connecting to server attempts increment with the final service failure error page. I’ve ensured that Ports 80-85 and 4445 are open and listening. As they have been all along. Tried different web browsers and different clients. And licensing is in place and valid. Running the fop2_server --test CLI all appears fine.

Anyone have any suggestions to narrow down the root cause? The box is a VM hosted on AWS, and the security group still appears to allow these ports to be accessed from our clients. I haven’t changed anything there either.

And I just went into my AWS CloudWatch logs and can see the ports 80 and 4445 being hit from my remote client are accepted as OK. So it’s not like AWS is dropping these packets. Strange. Tried dumping the web cache, temporarily disabling local AV on the client, etc. Still no luck. Will try hunting down the FOP2 logs on the server in a sec…

So I verified that TCP Port 4445 is up and listening on the server. And that this port is accessible from one of our company WAN public IP’s. See below. Still trying to figure out where the FOP2 logs would be located.

FOP2 Listening Port

Is there a firewall running on the server itself?

The FreePBX bundled intrusion detection firewall, but I don’t see anything odd in there. My company WAN IP endpoints are all whitelisted as being allowed access.

Where I’m over a barrel is that looking in the FOP2 company forum, it’s pretty stale and there are a few posts about little/no vendor response. Ugh…

Sure enough, doing a quick fwconsole firewall stop and fwconsole firewall start resolved the issue. First time I’ve ever had that happen. And we only have two receptionists at two company sites who access this FOP2 web app. The ports are closed to networks outside of our own. At least it’s fixed!

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.