FOP Couldn't load variable.txt?aldope=xxxx

I’m building a new system rather than trying to move my current Trixbox installation over to FreePBX in the hopes that it’s a cleaner install.

I’ve put together a new FreePBX installation and have configured my extensions, trunks, etc. with the exception that I have not defined the endpoints in the extensions yet, and I currently have the trunks disabled so as not to create a conflict with the existing Trixbox machine.

When I try to open the FOP in it starts to load then gives me a “Couldn’t load variables.txt?aldope=23077” error. If I retry, the numbers at the end change each time but the rest of the error remains the same. I get the same results with multiple browsers and from the Panel tab in the FreeBPX Admin screen.

Under the advanced settings tab for the Flash Operating Panel I currently have:
Disable FOP False
FOP Password combination of text, symbols, and numbers
FOP Sort Mode Extension
Start FOP with amportal False

Any suggestions?

Thanks. I had tried changing amportal False to true without success. After reading your post I realized I’d need to restart the server before it would take effect. That worked.

Change “Start FOP with amportal False” to true. Then start FOP. With amportal restart_fop

Hello, I have the same problem as the OP but when I attempt to run amportal restart_fop, I get the following and error:

amportal restart_fop
Please wait…
Asterisk is already running
Can’t listen to port 4445

The FOP’s server ( could not start!
Please correct this problem

I am using the FreePBX Distro, FreePBX and I did not upgrade from standard FOP. I just install FOP2.
Please advise.

EDIT: It at least appears to be working at the GUI level…it shows that OP Panel is ok, but I still get an error suggesting that it cannot start the FOP server…still curious about what could be going on.

I am having the same error, GUI is ok but i ger coupld not start. Any help is really appreciated.