FollowMe hangs up the call after few rings when dialling an external cell phone

I have setup FollowMe on my internal extension with the following settings:

Initial Ring Time: 0
Ring Strategy: ringallv2-prim
Ring Time: 30 seconds
(to allow sufficient time for my cell phone to ring - for testing purposes I have disabled Voice Mail on my cell phone)
Follow-Me List: and #
(have listed my own extension in the list so that I can see the incoming calls while I am already engaged on the phone on the first line - I have enabled Call Waiting on my extension)
Destination if no answer: Voicemail: <myextension: unavailable>

I should add, I have setup an incoming DID route and set its destination to my extension, which simply goes directly to FollowMe.

Here is the outline of the problem:

  • When I test this setup from an internal extension phone (i.e. use another internal phone to call my own extension), this works perfectly fine and for each ring strategy - the setup works as expected and my cell phone rings until the 30 seconds ring time is reached and then the call is put to voice mail.

  • When I test this setup by calling my DID from any external phone (i.e. from my analogue line from home, from another mobile phone, Skype, etc.) the setup does not work as expected. When the call comes in, I can see my extension ringing and immediately (after few seconds) my cell phone starts to ring, however after few ring tones the call to my cell phone is unexpectedly terminated and on the remote external phone I get the message from the telecom provider, that the call can not be established and after that, my call is terminated. This issue occurs almost exactly the same for any ring strategy I choose - the only difference is that some times the cell phones rings 1 or 2 seconds longer. Obviously, I expect the cell phone to ring until the 30 seconds limit is reached and then the caller should be put to voicemail - this unfortunately does not happen.

At the end, I should add that our internal PBX uses a SIP trunk to an external PBX (both PBXs are the same Asterisk/FreePBX based), which then registers to an external VoIP provider. Therefore all incoming and outgoing calls go through the same route through the same VoIP provider. I have checked my cell phone GSM provider and the VoIP provider and neither cause the problem. Our network resources and network configuration also is not the problem.

Going to into Asterisk CLI shows, that the call is being made to my cell phone with making progress (etc), however then suddenly for no reason the hangup message throws in without any errors and the entire call is immediately terminated making the caller unable to either reach me or leave a voice mail.

I have looked everywhere and tried everything (even upgraded to the newest FreePBX version) - obviously to my best knowledge, although I must say although I am learning quickly, the Asterisk/FreePBX area largely remains to be explored by me :wink:

Any help would be greatly appreciated.

FreePBX Core:
Asterisk 1.4.17~dfsg-2ubuntu1



I believe this part isn’t well programmed, have problems with inbound routing + follow me & cell phone as well…

[quote]I believe this part isn’t well programmed, have problems with inbound routing + follow me & cell phone as well


Nice comment and a great way to get people to help you.

It’s not the code.

This sounds like a problem we had. If so the issue is a related to a security control your trunk provider has built in. Essentially they don’t allow an external SIP call to go into your PBX and then back out. I think it had to do with potential long distance billing abuse that becomes possible because of number spoofing. Our work around was to purchase a second trunk and create a dial plan so that all follow me “forward” go out the secondary trunk. BTW- the cost of the second trunk wasn’t bad ($25) and I felt it may be useful for redundancy purposes.

Follow me now works well. Actually, too well (perfectly). Now I am looking for a way to disable follow me if the first extension is in use. In other words, if the caller is on the first line, don’t follow to the cell phone, go to the PBX voice mail. The recipient can’t do two things at the same time!

Any feedback is appreciated.

hmm - sounds like you have not had much experience working with telcos, it’s never their fault, ask anyone who has spent time working with them:-) (Not to say this is or is not their fault, but making a comment like that will immediately make anyone knowledgeable who is reading your post question you judgment.)

Anyhow, from what you describe, the problem clearly appears to be the telco provider does not like what you are sending them. Either you have not formatted the forwarding number properly or they are not happy with the CID you are forwarding on to them (which is the most common issue we see). Try clicking “Never Override CallerID” on that trunk and see if it helps.