FollowMe CID Again


I have the opposite problem of most recent posters, when I receive a FollowMe call to my cellphone, I get my asterisk DID as caller ID, what I want is the external caller ID forwarded.

My asterisk server version is: 1.2.23, and I am running a trixbox, with all yum updates, and FreePBX version

I set up FollowMe to call my cellphone using Ringallv2, and cellphone number entered as 503-XXX-YYYY#, I don’t understand the meaning of ‘#’ in this contect, I just saw a forum post describing this way as simpler than making an extension that is aliased to an external number.

I am using, which allows me to set CID, when I removed CID from the PEER configuration, and outbound route, the PEERNAME appeared in forwarded call caller ID, when I removed the PEERNAME from the trunk outgoing settings, my DID reappeared.

Is there something basic I am missing?


I got the followme callerid working (by retransmitting incomming caller ID) finally, although I realized it was working after I gave up. It seems to me that some configuration updates might need more than one reload of the asterisk server, as none of my tests showed the right CID being retransmitted.

I also noticed that after installing, for the first few reboots/reloads, the incoming call datestamp was 2/1 (or 1/2), and after a while, it suddenly started working right.

My SIP provider gave me the following template for trunk configuration outgoing settings:

For getting the proper ‘FollowMe’ CID, I had to check the ‘Never override CID’ checkbox, and remove the ‘fromuser’ and ‘username’ trunk settings, and use a dedikated trunk and outgoing route for Followme calls.