Follow Me

After changing to trunks from SipStation, my follow me calling to my cell phone no longer works.

I suspect that a + is being added or is missing but no positive and don’t know how to fix this.

Does anyone have an idea on how to fix this?


First of all - I would check to see if you can dial the number you are forwarding to in follow me from a phone connected directly to the system, to ensure the trunks are working.

Then, if that works, the most likely culprit is that the receiving carrier ( may not accept a forwarded SIP call without a proper header. In simpler terms, the they don’t like the caller ID you are sending them because FreePBX by default passes through the caller ID of the original caller, not the extensions’ caller ID. The carrier knows you down “own” the phone number being sent to them as caller ID so it refuses the call.

Try forcing the caller ID on your outbound trunk to the phone# you got from Bandwidth to see if that solves the issue.

Thank you for your help. I tried your suggestion but it didn’t help.

As it turns out, after hours of troubleshooting, the problem was alerts. “Alert” settings in followme or inbound routes are used to define different rings for distinctive ring. Once I cleared this setting, everything worked normally.

Apparently, rejects calls with this setting included.

ahh—The “ALERT-INFO” header? That would make sense.