Follow Me ringallv2 strategy not working as expected

I updated FreePBX modules to the latest 13 branch versions from an older 13 release. I am running Follow Me 13.0.38.10, core 13.0.120.10, framework 13.0.192.16, and recordings 13.0.30.11.
The extensions with FM enabled all use the ringallv2 strategy where it should “ring Extension for duration set in Initial Ring Time, and then, while continuing call to extension, ring Follow-Me List for duration set in Ring Time” which is how it was working before the update. Since the update I now get two calls to the extension, one for the initial ring time and a second one for the Follow Me List ring time - two calls are simultaneously ringing to the extension during the follow-me ring time. I have attached a sample CDR and call event log screenshot, a ‘core show channels’ output during inital ring time and after, and a follow-me settings screenshot of the dialed extension. I have an asterisk full log if needed. My understanding of ringallv2 is the follow me channels are created at 12:07:03 during the initial ring time but are set to sleep/wait for the duration specified and then proceed. I do not expect to see new channels at 12:07:09. In the logs you can see the extra channels appear after the 5 second inital ring timeout.
I have tried to reapply the follow me settings as I want them, tried ringall which works as expected with dead air between initial ring and follow-me ring, tried to downgrade follow me to 13.0.37.2, and tried the edge release 13.0.38.11 all with no change in behavior. Can anyone reproduce this or have any guidance?


During inital ring time

rut-asterisk01*CLI> core show channels
Channel Location State Application(Data)
SIP/7181-000002c2 [email protected] Ringing AppDial((Outgoing Line))
SIP/7180-000002c1 [email protected]:21 Ring Dial(Local/[email protected]
Local/[email protected] [email protected]:52 Ring Dial(SIP/7181,25,trM(auto-blkv
Local/[email protected] [email protected]:1 Ringing AppDial((Outgoing Line))
Local/FMGL-912018xxx [email protected] Down Return()
Local/FMGL-912018xxx FMGL-912018xxxxx2#@f Ring Wait(1)
6 active channels
3 active calls
525 calls processed

After inital ring time

rut-asterisk01*CLI> core show channels
Channel Location State Application(Data)
Local/[email protected] [email protected] Down Return()
Local/[email protected] [email protected] Ring Dial(SIP/NexVortex_1/12018xxxx
SIP/7181-000002c3 FMGL-912018xxxxx2#@f Ringing AppDial((Outgoing Line))
SIP/7181-000002c2 [email protected] Ringing AppDial((Outgoing Line))
SIP/NexVortex_1-0000 [email protected] Down AppDial((Outgoing Line))
SIP/7180-000002c1 [email protected]:21 Ring Dial(Local/[email protected]
Local/[email protected] [email protected]:52 Ring Dial(SIP/7181,25,trM(auto-blkv
Local/FMP[email protected] [email protected]:1 Ringing AppDial((Outgoing Line))
Local/FMGL-91201xxxx [email protected]:1 Ringing AppDial((Outgoing Line))
Local/FMGL-91201xxxx [email protected]:21 Ring Dial(SIP/7181&Local/912018xxxx
10 active channels
4 active calls
526 calls processed

Here is the CDR and call event log

I can kind of confirm. Similar circumstances. Recent upgrade to current including second core update. I just tried your solution and it appears to work although it didn’t ring the 20 seconds before pulling back to voicemail.

Add to this spurious reports of calls not going to voicemail when using followme and only 1 extension. It seems that turning followme off and then back on fixes those ones. I didn’t notice on the one I assisted on whether the strategy was ringallv2 or just ringall.

1 Like

I have an update to this. Thanks to wwenthin, it got me thinking that the ringallv2 strategy does not reside in the FollowMe module, but perhaps in a dependency. I rolled back core to 13.0.119.10 and then FollowMe worked as expected. I upgraded core incrementally and found it works up to 13.0.120.3 but breaks in core version 13.0.120.7. I would like someone to confirm this for me so I can submit the problem to the issue tracker. Anyone?

I am noticing similar behaviour on a PBX that I maintain.

With FollowMe enabled, extensions are getting double calls to their clients. And if they enable the CallForward feature (using feature codes) The call does not progress to the CallForward destination, but does to the extensions voicemail.

Its feeling like the FollowMe is following though on one of the Followed extensions and then Voicemail is picking up the call right away.

I’d rather not have to roll back, but its looking like I might have to to get this to work again. What models did you have to roll back and to which versions? I tried rolling back just the core module to your suggested version 13.0.120.3 but this didn’t resolve the problem.

Thanks!

Actually… scratch that. I downgraded my Core to 13.0.120.3, and had to disable and re-enable Follow me before it worked as expected again.

Looks like @wwenthin is correct in that there is a core dependency missing

Find Me Follow me relies on Core for dialparties.agi, it also has a dependency on core (https://github.com/FreePBX/findmefollow/blob/release/13.0/module.xml#L65) so a dependency isn’t missing.

What you should probably do is add information to this ticket:

https://issues.freepbx.org/browse/FREEPBX-13726

Please also provide call logs either here or in the ticket ^