Follow-Me not ringing remote phone when Confirm Calls is enabled. Works otherwise


#1

Good day!

I have a customer with a FreePBX system installed about 1 1/2 years ago: FreePBX Distro: SNG7-PBX-64bit-1805-1, Release Date: May 2018, FreePBX 14 • Linux 7.5 • Asterisk 13

I can setup Follow-Me on an extension to a cell phone (using format 8885551212#) and it works fine. The incoming call to the extension rings the cell phone number in the Follow-Me configuration.

However, when the “Confirm Calls” is enabled, the cell phone doesn’t ring at all. I’ve tried long Follow-Me Ring Times (45 seconds) and various Ring Strategies (ringall, ringallv2, ringall-prim, ringallv2-prim). I just don’t understand why enabling the “Confirm Calls” prevents the call phone from even being called.

Does anyone have any suggestions? I did upgrade the Follow-Me module, but I’m a bit hesitant to just upgrade all FreePBX Modules and/or Asterisk because this is a production system. Especially because I don’t know that an upgrade will fix this issue.

I do have debugging logs with Confirm Calls enabled (where the follow-me number doesn’t ring) and with Confirm Calls disabled (where the follow-me phone does ring), if someone wants to see them. They are several hundreds of lines each so I’m not including them here.

I certainly appreciate any help that anyone wants to provide!

Dave


(Lorne Gaetz) #2

share a problem call trace with pastebin:
https://wiki.freepbx.org/display/SUP/Providing+Great+Debug#ProvidingGreatDebug-AsteriskLogs-PartII


#3

Here is the failed follow me log: https://pastebin.freepbx.org/view/d2429f52
And the working follow me log: https://pastebin.freepbx.org/view/d182b0b9


(Lorne Gaetz) #4

What version of the Core module are you using?

fwconsole ma list | grep core

#5

| core | 14.0.18.22 | Enabled | GPLv3+ |

Thanks for your help! I’m back on-line and I’ll be glad to give you any information you want.

dave


#6

The fact that you are asking me about versions (instead of configuration), led me to find this: https://issues.freepbx.org/browse/FREEPBX-18728. At first glance, this seems to match both my symptoms and also the timeframe of the server. If I understand this correctly, it seems like the problem is with FreePBX core and not the underlying Asterisk.

Should I just upgrade the FreePBX Core Module? Any precautions that I should take first?

Thanks so much!


#7

After upgrading the FreePBX Framework and the Core modules in Module Admin the Follow-Me with Confirm Calls is working now. Thanks!


(system) closed #8

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.