Follow me/locator not working... sent into invalid extension 'FM201' in context 'ext-findmefollow', but no invalid handler

[May 24 18:50:59] VERBOSE[2379] logger.c: – Executing [[email protected]:50] Set(“SIP/210-b7d049a8”, “VMX_EXT=FM201”) in new stack
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: Set
[May 24 18:50:59] VERBOSE[2379] logger.c: – Executing [[email protected]:51] GotoIf(“SIP/210-b7d049a8”, “1?getdest”) in new stack
[May 24 18:50:59] VERBOSE[2379] logger.c: – Goto (macro-vm,vmx,56)
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: GotoIf
[May 24 18:50:59] VERBOSE[2379] logger.c: – Executing [[email protected]:56] GotoIf(“SIP/210-b7d049a8”, “0?vmxpri”) in new stack
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: GotoIf
[May 24 18:50:59] VERBOSE[2379] logger.c: – Executing [[email protected]:57] Set(“SIP/210-b7d049a8”, “VMX_CONTEXT=ext-findmefollow”) in new stack
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: Set
[May 24 18:50:59] VERBOSE[2379] logger.c: – Executing [[email protected]:58] GotoIf(“SIP/210-b7d049a8”, “0?vmxgoto”) in new stack
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: GotoIf
[May 24 18:50:59] VERBOSE[2379] logger.c: – Executing [[email protected]:59] Set(“SIP/210-b7d049a8”, “VMX_PRI=1”) in new stack
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: Set
[May 24 18:50:59] VERBOSE[2379] logger.c: – Executing [[email protected]:60] Goto(“SIP/210-b7d049a8”, “ext-findmefollow|FM201|1”) in new stack
[May 24 18:50:59] VERBOSE[2379] logger.c: – Goto (ext-findmefollow,FM201,1)
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: Goto
[May 24 18:50:59] VERBOSE[2379] logger.c: == Channel ‘SIP/210-b7d049a8’ jumping out of macro ‘vm’
[May 24 18:50:59] DEBUG[2379] app_macro.c: Executed application: Macro
[May 24 18:50:59] VERBOSE[2379] logger.c: == Channel ‘SIP/210-b7d049a8’ jumping out of macro ‘exten-vm’
[May 24 18:50:59] WARNING[2379] pbx.c: Channel ‘SIP/210-b7d049a8’ sent into invalid extension ‘FM201’ in context ‘ext-findmefollow’, but no invalid handler

Thats the error… here is the config in extensions_additional.conf

[ext-findmefollow]
include => ext-findmefollow-custom
exten => FM201,1,Goto(201,FM201)
exten => 201,1,GotoIf($[ “${DB(AMPUSER/201/followme/ddial)}” = “EXTENSION” ]?ext-local,201,1)
exten => 201,n(FM201),Macro(user-callerid,)
exten => 201,n,GotoIf($[“foo${BLKVM_OVERRIDE}” = “foo”]?skipdb)
exten => 201,n,GotoIf($["${DB(${BLKVM_OVERRIDE})}" = “TRUE”]?skipov)
exten => 201,n(skipdb),Set(__NODEST=)
exten => 201,n,Set(__BLKVM_OVERRIDE=BLKVM/${EXTEN}/${CHANNEL})
exten => 201,n,Set(__BLKVM_BASE=${EXTEN})
exten => 201,n,Set(DB(${BLKVM_OVERRIDE})=TRUE)
exten => 201,n(skipov),Set(RRNODEST=${NODEST})
exten => 201,n(skipvmblk),Set(__NODEST=${EXTEN})
exten => 201,n(skipsimple),Set(RecordMethod=Group)
exten => 201,n,Macro(record-enable,${DB(AMPUSER/201/followme/grplist)},${RecordMethod})
exten => 201,n,Set(RingGroupMethod=ringallv2-prim)
exten => 201,n,Set(_FMGRP=201)
exten => 201,n(DIALGRP),GotoIf($[ “${DB(AMPUSER/201/followme/grpconf)}” = “ENABLED” ]?doconfirm)
exten => 201,n,Macro(dial,$[ ${DB(AMPUSER/201/followme/grptime)} + ${DB(AMPUSER/201/followme/prering)} ],${DIAL_OPTIONS},${DB(AMPUSER/201/followme/grplist)})
exten => 201,n,Goto(nextstep)
exten => 201,n(doconfirm),Macro(dial-confirm,$[ ${DB(AMPUSER/201/followme/grptime)} + ${DB(AMPUSER/201/followme/prering)} ],${DIAL_OPTIONS},${DB(AMPUSER/201/followme/grplist)},201)
exten => 201,n(nextstep),Set(RingGroupMethod=)
exten => 201,n,GotoIf($[“foo${RRNODEST}” != “foo”]?nodest)
exten => 201,n,Set(__NODEST=)
exten => 201,n,dbDel(${BLKVM_OVERRIDE})
exten => 201,n,Goto(ext-local,vmb201,1)
exten => 201,n(nodest),Noop(SKIPPING DEST, CALL CAME FROM Q/RG: ${RRNODEST})

; end of [ext-findmefollow]

you must have some sort of modification from the stock dialplan overriding the auto-generated plan. The extension exists:

exten => FM201,1,Goto(201,FM201)

As a sanity, try the following at the CLI to confirm it is not seeing it:

dialplan show [email protected]

or “show dialplan” if you are using Asterisk 1.2.

p.s. make sure you have reloaded the configuration (pressed the orange bar) after creating it, you can type “reload” at the CLI to manually do such.

Did the dialplan show [email protected] and it comes back with the following…

chewbaccaCLI> dialplan show [email protected]
There is no existence of ‘ext-findmefollow’ context
chewbacca
CLI>

which makes no sense… I don’t have any modification over the stock dialplan… if you wnat I’d be willing to give you tempoarry access to look around…

Thanks,
Dan

Dan,
you may want to check if someone is on the IRC who may be willing to take a closer look. Without purchasing support credit I can’t go onto your system and look around to see what is up but you may find someone there who is willing to for free.