Follow Me doesnt see that call was completed

I am trying to set up Followme, I have configured the inbound and outbound routes, I can place calls outbound however when I call into the PBX from an outside line and hit an exstension with a external follow me number, the call will be placed but doesn’t realize that it was ever picked up. The caller will just keep ringing and ringing until you hot the ringtime set in the followme settings.

I am on freepbx 14 and asterisk 13, clean install from the distro. Using a Flowroute PJsip trunk.
I am not behind a commecial firewall, just freepbx’s. I didn’t put the server into the DMZ like it suggests but I don’t think thats the deal. I have also fowarded UDP 10000-20000 to my Server.

I assume its probably network related but not sure

If you don’t have a firewall, how are you forwarding ports 10000-20000 to the server? If you are forwarding those, are you also forwarding 5060 and 5160 to the server?

Sorry I am behind a firewall per-say but its just the one built into an ASUS Router, not a seperate appliance firewall. I Will have to check about 5160 but I know for sure I forwarded 5060.

I verified all ports were forwarded, I even placed the FreePBX server in the DMZ and it did the exact same things

Try adding progressinband

I am Using the Chan_PJSIP trunk so I don’t have an “Other SIP Settings” I sent an email to FLow route and they took a look at the call and said that I was reporting My local IP on the call out? so obviously they wouldn’t know how to get back. Any Idea on that?

So something, somewhere, doesn’t have the NAT=YES setting turned on correctly. This happens when you have “NAT=NO” in one of the pertinent sections.

So we’re clear, there are at least three places where this is needed. The first is on the phone, especially if the extension is "NAT"ed from the PBX’s perspective.

The second is on the SIP Settings which manages the config of the trunk. The “combination” screen in the Advanced SIP Settings (which affects both Chan-SIP and PJ-SIP) need to make sure that these are set.

Finally, you need to make sure that the extension is set to properly set the NAT settings for your application. This goes in the Extension configuration on your PBX (and should match what you set on the phone).

Since this is FMFM problem, I’m going to suggest that your “main” NAT setup is incorrect, although it pays real dividends to make sure it is correct in all three places.

Thanks for the Reply Cynjut, I don’t have any physical devices set up, this is solely just Inbound route pointed to an extension which has followme enable on it and pointed back to an outside line.
NAT settings have never been changed off from YES from a clean install. and the NAT settings are set to Static IP (Which is the Public IP) and then define the subnet of the internal network.

I did not see any NAT setting in the extension settings.

OK, just so I’m clear. You have a Follow Me set up for an extension that doesn’t actually have a phone connected to it? I understand that when you have a hammer, everything looks like a nail, but there has got to be at least one better solution than this, including (but not limited to) using a Ring Group with the outside line as the only entry or a Misc Destination set up with the outside line as the destination. There have got to be no less than 5 ways to do what you are doing.

Also, the NAT setting for most extensions is on the last (Misc settings, IIRC) tab. Of course, the specific location of that setting is going to change depending on the version of FreePBX you are using. It’s moved around quite a few times over the past 10+ years.

I am fairly new to phone systems in general so I actually didn’t realize that you could do the Misc destinations. Which i will do for the agents that dont have desk phones. I will eventually set up physical phones but the phones that I am going to use are still in use at this time. So I was just playing around with getting everyhting set up.

Just for the record. a MISC Destination does the same thing As I described. BUT i think my problem is the router/firewall I am behind WILL NOT open port 5060… I tried every way from Sunday to up that port and every single port checker I use tells me that the port is closed. I have forwarded port 80 and 22 for remote management so I know that it is capable of forwarding the port… It just wont do it. So I am going to try a different router and see if that will make the difference.

Thanks for all your help so far! I’ll Let you know how the new router goes

I was Dumb on this one. I had other devices on the network that were using port 5060 to communicate with a internet hosted PBX, I took the phones all offline and signaling started working

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.