Flite does not work after upgrade of 1.810.210.57-1

After upgrading to 1.810.210.57-1 flite does not work. If I run “core show application flite” it is not loaded. Does this work anymore?

No Problem, not in a hurry. One other thing I noticed is that when wanpipe loads it will not allow iptables to load. If I turn off the service for wanpipe, iptable will load. Just curious if you seen this.

Nope it would appear the module refused to load with asterisk 1.8.10. I will try and get sometime this weekend to look at it.

Nope never seen it before but I do very little with IPTables. That is what hardware firewalls are for.

Can you test this flite for me. If it works I will fix it in the upgrade script and kickstart for new installs

yum clean all
yum update asterisk18*
yum install asterisk18-flite*

Than restart asterisk and tell me if flite loads now.

I also tried that and still can not load it

core show application flite
Your application(s) is (are) not registered
Command ‘core show application flite’ failed.

Tony,

Same results as esarant. Did not load. If do a complete reboot of the system and watch the screen as the services start you will notice that IPTable fails on startup. If you disable wanrouter not to start IPTables will load. I do agree with you on having a hardware firewall but most firewalls will not detect a sip breach on port 5060 like fail2ban does which uses iptables to stop the attack.

Ok back to the drawing board on Flite.

As far as wanpipe I can start iptables just fine with wanpipe running on the same version you have. My guess is its some rule you have setup in iptables. remember sangoma cards show up as network devices.

OK I looked into the wanrouter problem further. There is no /etc/wanpipe/wanpipe1.conf file. So when it tries to start it fails on that. Since it is an interface it causes iptable not to start. I don’t have a sangoma card in the box so I guess when the upgrade happened it did not create a config file. After going through the sangoma information, I do not see how to configure the config file for no board installed in the system. So for now I will disable the wanrouter service. If you have any info that can help, please advise me.

Ok finally tracked down flite issue. The newest RPMs were compiled with flite and flite-devel yet the PBX’s do not have flite-devel. I fixed this in the latest upgrade script and for new installs. Simply do a yum install flite-devel than restart asterisk and it should be back up and working again. Thanks for reporting this issue.

Either I am jumping the gun or the repos have not updated yet. I tried to do what you said but this did not work. Stills fails. When I tried to “yum install flite-devel” it would fail due to it being installed already. I removed the package and reinstall it. No help. ??

OK well if it is installed it should work. It works on both my test systems. Are you using 32 or 64bit

32 bit

This is what is installed

[[email protected] ~]# yum list | grep flite
asterisk18-flite.i386 1.8.10.0-24 installed
asterisk18-flite-debuginfo.i386 1.8.10.0-24 installed
flite.i386 1.3-11.el5 installed
flite-devel.i386 1.3-11.el5 installed
asterisk18-app_flite.i386 0.6-8 pbx
asterisk18-app_flite-debuginfo.i386 0.6-8 pbx

Remove the

asterisk18-app_flite
asterisk18-app_flite-debuginfo

yum -y erase asterisk18-app_flite*

Both of those should be removed with the upgrade script

Than restart asterisk

If you notice that they are not installed. Just what is avaliable on the repo.

Tony, I tried to load the app_flight module manualy in the cli and it would error out. I copy the module from a system that had 1.89.210.57-2. The files sizes were different. I can now load the module with no errors. I do see that all the modules are different sizes. Almost all are much smaller. I am going to test the system out more. I don’t know if when you compiled the asterisk system it made some mistakes in the modules. The system was running good when it was 1.89.210.57-2. As you can see in my previous post I am having troubles with the wanrouter. I am not sure if it is due to not having a sangoma card in the box. I know in the previous version the wanrouter was not installed. Hope all this info will help you out.

Same problem here, it wont work after yum install flite-devel.
core show application flite returns nothing.

[code]

yum list | grep flite
asterisk18-flite.i386 1.8.10.0-24 installed
asterisk18-flite-debuginfo.i386 1.8.10.0-24 installed
flite.i386 1.3-11.el5 installed
flite-devel.i386 1.3-11.el5 installed
asterisk18-app_flite.i386 0.6-8 pbx
asterisk18-app_flite-debuginfo.i386 0.6-8 pbx[/code]

OK finally tracked down and fixed.

yum update asterisk18*

Than restart asterisk and it Flite will work.

Also please note that any users running the upgrade script as of today the upgrade scripts will have Flite installed correct.

Perfect, Everything worked like a champ. Thanks Tony for your hard work and supporting us.

Yup, it works now. Thank you Tony

Just a re-cap:

yum -y erase asterisk18-app_flite*
yum clean all
yum update asterisk18*
yum install asterisk18-flite*
yum install flite-devel

And then restart asterisk. Hope I am correct :slight_smile: