Flash Operator Panel Disabled on New Install

Just did a fresh install of the Distro 1.8.1.4-3. I noticed that the FOP did not work. For some reason, FOP is disabled and will not start by default on a new Distro install. Can be re-enabled in the Advanced Settings module. However, since FOP was enabled by default in prior releases, I assume that this a “bug” or an oversight.

I also had to reboot my machine after enabling the FOP before it would actually work…

FOP1 isn’t supported anymore. Since FOP2 is not a free app we are working with Nicolas to get it in the app store. For now it’s a simple download.

Fair enough. Although I found FOP mostly worthless as a tool for managing calls, it was sometime useful just in getting a picture of what was going on on the system.

Can you PM me some simple instructions for the simple download process, and I’ll add them to the FreePBX documentation pages?

I think it is in the repo, so ‘yum install fop2’

If you can wait until the weekend I can check it out.

Since I was using FOP2 prior to the distro I just wget the RPM from www.fop2.com then install the RPM.

The more I think about it, the less this makes sense.

FreePBX Distro specifically asks you to set the FOP password on the first install. Why do that if FOP is disabled?

FreePBX Distro has an option ON THE MAIN GUI PAGE to access the FOP. That option appears even if FOP is disabled. If you click on the FOP icon when FOP is disabled (as it is by default), you get an error message. Why have an icon on the main GUI page to access FOP if FOP is disabled by default?

Are you sure this was a deliberate decision, and not an oversight? In prior versions, FOP was enabled by default. …

Installing FOP2 fixes all of these issues.

Perhaps, but it still seems weird for the reasons I stated. It would make more sense to leave the FOP active (as it was in prior versions) until FOP2 is included as a permanent replacement.

Just my humble opinion. This particular change has already resulted in help posts asking why FOP is returning an error…

I strongly agree with AdHominem, this is clearly a bug…

There is an icon on the main screen of the FreePBX distro to go to FOP, and now this presents the user with a confusing error message!

It took me a while to figure out they disabled FOP in the latest version, it sure looked like a bug.

I can’t see any reason why FOP can’t be left enabled by default as it has always been?

Thanks,

How can i remove the FOP link from the main page?

Edit the index.php file in the www root.

Just tried “yum install fop2” as suggested above said “No Package fop2 available”. Can you provide instructions for installing or enabling fop? Also, the link to www.fop2.com is dead

Take a look in the FreePBX store.

Hi Skyking – I remember you from the Trixbox forum. You were extremely helpful to me. I’m finally getting rid of Trixbox and trying to set up FreePBx (like you suggested I do a long time ago).

Which commercial module would provide FOP functionality?

Ummm, FOP2 - That was easy.

Unfortunately, I’ve been playing with myself on Trixbox for so long that I’ve gone blind!
I’m looking right at the http://www.freepbx.org/commercial-modules page and I still can’t see it!

I think you have to sign up for a free portal account then you will see it. I did not click on store I was in the reseller portal.

I think that is to buy the license. I just noticed it’s in the yum repo, did you look?

[[email protected] tftpboot]# yum list | grep -i fop
/usr/lib/yum-plugins/kmod.py:25: DeprecationWarning: the sets module is deprecated
from sets import Set, ImmutableSet
fop2-fpbx.i386 2-2.26.2 @pbx1