[FIXED] 32bit 6.12.65 with Asterisk 11 - Distro fails to install correctly

Distro install number 5!!!

Tried 64bit and 32bit alpha install with asterisk 13… both failed (see previous posts)
Tried 64bit and 32bit stable build with asterisk 13… both failed (see previous posts)

Tried 32bit stable build with asterisk 11… guess what… failed.

Gui for this one gives the following…

fatal error reading freepbx_settings
Trace Back/var/www/html/admin/libraries/BMO/Freepbx_conf.class.php:218 die_freepbx()
[0]: fatal error reading freepbx_settings
/var/www/html/admin/libraries/BMO/Self_Helper.class.php:116 Freepbx_conf->__construct()
/var/www/html/admin/libraries/BMO/Self_Helper.class.php:50 Self_Helper->autoLoad()
[0]: Freepbx_conf
/var/www/html/admin/bootstrap.php:102 Self_Helper->__call()
[0]: Freepbx_conf
/var/www/html/admin/bootstrap.php:102 FreePBX->Freepbx_conf()
/etc/freepbx.conf:9 require_once()
[0]: /var/www/html/admin/bootstrap.php
/var/www/html/admin/config.php:99 include_once()
[0]: /etc/freepbx.conf

I, personally, have installed a bunch of machines, both physical and virtual, without problems recently.

Can you tell me EXACTLY what you’re doing, and how you’re doing it? I have a suspicion that you’re using virtualization software that’s messing with the install process?

Hi there…and thanks for the reply.

I’m using Microsoft’s Hyper-V.
I create a VM with a single CPU and 1 core, 1024Mb ram and 50Gb hard disk.
I install using the Distro ISO and (apart from regional location) choose all the defaults for a full install. I have tried Auto and Manual IP setup for the 64bit version without success. I have tried Alpha and Stable versions as well as Stable with Asterisk 11…none of which complete fully and successfully. I seem to get different issues depending on the Distro being used and all of the issues (for 32bit Distros) relate directly to either the Asterisk DB, Asterisk Modules or the GUI not displaying the contents of the config.php file. The 64bit versions just don’t see the internet at all.

I have manually installed and run Debian Wheezy, CentOS, Ubuntu 12/14 with Freeswitch on MS Hyper-V without any issues.

Any ideas would be very greatly appreciated. I’ll have a go with Virtualbox today to see if I get any further.

There is often an option to let HyperV do the install for you, and that sounds like the problem.

Create a new VM, and do NOT link the ISO to it. Turn it on, make sure it boots (and errors) and only then attach the ISO to it. If the software says something like ‘I see you’re trying to install RHEL, would you like me to help?’ – or something similar - say NO. That’s what’s breaking your install.

Hi Rob

Thanks for that…I have to admit that it’s utterly bizarre…but that approach worked. I didn’t get asked anything about RHEL at all but all of the builds now seem to install and run first time.

I did have one small issue though with my preferred option - 64bit Alpha running Asterisk 13…

The ‘Apply Config’ button is red and gives the following error when I try and run it…

Error!Reload failed because retrieve_conf encountered an error: 255exit: 255
PHP Fatal error: Class ‘FreePBX\modules\Extensionroutes\licenseCheck’ not found in /var/www/html/admin/modules/extensionroutes/Extensionroutes.class.php on line 451

I’ve tried googling this but haven’t found any reference to the licenseCheck module anywhere. Not sure if it’s something you might have come across?

Many thanks


hahaha…actually resolved that one! Didn’t realise you had to activate the software!


Actually, you don’t. As I’m off in Toronto at the Dev Meeting up here (With Matt Jordan from Asterisk, too – https://twitter.com/xrobau/status/593403915187662849 – and the PHP Hammer!) I’ve managed to (twice) now publish a broken Extension routes module, as I don’t have my proper testing environment with me. I’m going to publish it again, fixed properly this time. Sorry about that :sunglasses: