First start of Freepbx missing lots of modules

I have done a new install with FreePBX Distro Centos 6.2 Freepbx version,

When I entered the IP of Freepbx PC to open the GUI, it took a very long time, I entered my new user and password etc. and continued to GUI, after taking almost 5 min it’s in, I went to admin to do a restore from a backup I have made and found that Backup and Restore aren’t highlighted so is a lot of the modules including Extensions, I even tried to make changes in Module Admin and when it asked me to apply I received an error " error: Did not receive valid response from server, XHR response code: 0 XHR responseTEXT: undefined jQuery status: timeout" Not sure what the problem is, I have installed this 3 times due to some other error I have found on Centos but the previous ones worked, I hope there is a why to fix this with out reinstalling the CD again, I’m using the same PC as a Backup system and it’s not easy to get it working for me with little linux background.

Is there a why to yum reinstall or some other why to re-install via command. Please I really need this to work. Thank you.

Sounds like you have local DNS problems. The jQuery message is because it was trying to communicate with your server but your server is timing out. (as you said from it taking 5 minutes to load)

Something is not right with your system. Installing the rest of the modules will only make it worse or break it further.

Ok, Not sure why that would be a problem, I have reinstalled the PBX PC due to an error I made with the mounting of a new HDD, causing the pc to stop working, and before it worked 100% and this time I used the same setup as previous, Just for info after tring to apply config I have received this message in the FreePBX Notices box " retrieve_conf, Config not applied … Reload failed because retreive_conf encountered an error:1 "

Is there a way to re-install FreePBX on distro with out re-installing the CD.


I have decided to do a re-install of the FreePBX Distro 6.2 CD, all is well now, Still not sure why it has happened but every thing is working now again… but will do some tests.