Firewall with IPv6 not allowing connection?


(United States) #1

Love FreePBX it’s been working great for past couple months. I have several endpoint outside of network and I have been going into the firewall and adding the IPs of the external networks. This method works great and haven’t run into any issues until today.

I went to add another phone and set it up just fine internal, when I went to add his IP and noticed his ISP gave him an IPv6 address. I added it to the firewall but no luck. Phone works on one of our other outside trusted IPv4 networks. Maybe it’s not the fact that it’s a IPv6 that is causing the problem, but like I said phone works elsewhere and other phones on outside networks work great.

Do I need to enable IPv6 somewhere? Am I entering the ipv6 IP incorrectly.

I got about 20 phones here and about 7 of them are external. Just at people’s houses so they can work at home.
FreePBX 14.0.13.12
Asterisk 16.6.2

Using a combination of Cisco/Chan-SCCP/SccpPhoneManager and grandstream pjsip endpoints, neither is working at that location, but both are working at different (IPv4) external locations.

Thanks for any input!


#2

Are the phones getting IPv6 addresses or IPv4 ?


(United States) #3

Everything is IPv4 except this person’s home ISP’s provided IP is IPv6.

Someone recommended I should look into setting up a VPN to get around this.


#4

Seems reasonable, tunnel the IPv4 SIP traffic inside IPv6 VPN, sure. This way only your edge devices worry about IPv6. Bonus that you get increased security as well.

The alternative would be to IPv6 all your networks. That’s a much bigger rabbit hole.


(system) closed #5

This topic was automatically closed 31 days after the last reply. New replies are no longer allowed.