Firewall not starting after reboot

I have a FPBX 15 fresh install. I then restored from a backup. Everything is working perfect… almost.

Whenever I reboot the server, the Firewall does not start automatically. (I noticed this via the Dashboard with the red X next to the firewall) Logging into the server and issuing a “fwconsole firewall start” immediately starts the firewall and all is well. What could be causing this not to start up on reboot?

I am running 15.0.31 version of the firewall module.


Hi @cloudpbxfuzz
Be sure your FreePBX modules are updated to latest version,
And try to find something on the logs.

i hope below command will give you some informations.
fwconsole debug



I see this:
Unable to connect to Database, sleeping 2 seconds and retrying. (1)

So perhaps it is trying to start the Firewall, but not all of the other services are up and running yet, so it gives up?

Did you tried to un-install and install again Firewall module ?

I have not. Will try that tonight.

Interesting. If I manually reboot the PBX by either logging in via SSH and issuing a reboot command, OR pressing the reboot button via the GUI, the firewall seems to come back normally after a reboot. If the system is rebooted via a cron job, using /sbin/shutdown -r now >/dev/null 2>&1, it does not seem to come back properly. The error log does not really show anything other than in the firewall.err log, it shows this:

ipset v7.1: The set with the given name does not exist
ipset v7.1: The set with the given name does not exist

This feels like a band aid, but a possible “solution” would be to fwconsole firewall start command in the crontab a few minutes after reboot. Although according to the crontab for the asterisk user, it checks every so often to see if the firewall is running.

Hi @cloudpbxfuzz
When you ran fwconsole restart to restart ALL Services at the same time Firewall going to start automatically ? Or you need to run separately fwconsole firewall start ?
What about your Module update ? All modules are up to date latest version ? ( core, framework, firewall ).

So some more info:

Last night, I did not have the server reboot automatically. I logged into the GUI this morning, and the same warning was there. (firewall not running) All modules are on the latest version, as well as all yum updates.

It happened again last night. I checked first thing this morning, and the firewall is completely off. fwconsole firewall start starts the firewall properly.

I cannot find anything in the logs about what might be causing this. This is a big security issue.

Anyone have any ideas where to start checking? I am running version 15.0.31 of the firewall.

This old post seems to be relevant. Firewall keep getting disable - #19 by jerrm

@jerrm @dicko @lgaetz Have you seen any other reports of this lately?

Reinstalling the module seemed to have fixed it.

1 Like

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.