File vm-youhave does not exist in any format

Hi,

Calls are working fine but Asterisk is having trouble when opening these kind of files. Log:

[2012-10-22 13:36:54] WARNING[7123]: file.c:667 ast_openstream_full: File vm-youhave does not exist in any format
[2012-10-22 13:36:54] WARNING[7123]: file.c:962 ast_streamfile: Unable to open vm-youhave (format 0x4 (ulaw)): No such file or directory

I tried to open up permissions (777) with no sucess. Also did “amportal chown” with no sucess. What more can I do?

Thanks in advance.

Borja

Did you look to see if the file exists? How did you install FreePBX? Distro or built by hand?

Yes, the file exists although not in ulaw format. Everything worked ok for long time. Now it stopped working…Everything built by hand. CentOS 6.2.

Maybe this helps: http://pastebin.com/KtPZvL0U I’m guessing it has something to do with permissions…Maybe mysql has to run as asterisk and not root?

If built by hand then you need to install the sound files for ulaw.

But Asterisk should be able to read gsm right?

This might help:

Here is the owning of processes in a working station:

http://pastebin.com/rw7yWGan

And this is what the NOT-working station shows:

http://pastebin.com/4f6HDtFB

Some components of mysql are not being ran by mysql, but by root. Could it be this?

Thank you.