Few seconds silence on VPN calls

Hi again,

I’m suffering an issue whit some calls and it only happens with Yealink phones whit openVPN client and FreePBX 13, with System Admin Pro’s openvpn server.

It normally works in the good way. Sound quality and latency is good, but sometimes, I get few seconds silence on one way. It use to be no more than 5 seconds aproximatelly.

I have only detected with calls between yealink phones that use their own openvpn client integrated and I think is a networking issue.

Does anyone know this case?



It’s not one way problem… it’s both ways problem. I have realizaed that silence is created in two ways.

Any idea? Regards.

One way audio in both directions is still one way audio.

Double check your network and firewall settings. Once the sessions get established in both directions, everything works, but for that first few seconds, the system is struggling to get the paths set up.

Yes i’ve noticed something very similar as well. Few seconds of no audio both ways mid conversation at a random time. Only once per conversation it seems.
Very recognizable when it happens it does not sound like latency, jitter, packetloss, etc.

That’s usually an RTP session timer running out.

Hey guys! Does it happen to you with yealink phones as well? with their own openvpn integrated client?


Yes!! Same to me!!


yes to both, yealink with built in openvpn client. doesnt happen on other phones

never heard of this, can you link to RFC please?

Not really, The UDP RTP sessions in the routers (or possibly in the VPN) sometimes expire if there are set too short. When they do, the router will reestablish the connection and life is good again. If this was ‘straight’ Asterisk, you would sometimes see a message about the remote being unreachable followed almost immediately by a recovery message.

Hi cynjut,

Do you mean something like this?

[2018-05-07 04:03:00] NOTICE[15091] chan_sip.c: Peer ‘301’ is now Lagged. (2048ms / 2000ms)
[2018-05-07 04:03:10] NOTICE[15091] chan_sip.c: Peer ‘301’ is now Reachable. (49ms / 2000ms)
[2018-05-07 04:03:44] NOTICE[15091] chan_sip.c: Peer ‘302’ is now UNREACHABLE! Last qualify: 57
[2018-05-07 04:03:55] NOTICE[15091] chan_sip.c: Peer ‘302’ is now Reachable. (50ms / 2000ms)



Well, about one year ago, I had same phones conected via same builtin vpn client to a debian based router, with openvpn server. The calls worked properly, without any silence/unregistering issue.

Now, the phones are connected directly to “system admin”'s openvpn service, and this makes the difference.

So, I suppose the server.conf configuration generates the issue, but I don’t know what parameters I have to change.

Am I right with this supposition?


At this point, I’m afraid I’ll have to refer you to an Issues ticket.

Write up how you used to have it set, how it’s set up now, and see if one of the Sangoma Professionals can look at it. It could be a bug, it could be an incompatibility with the two VPNs, or it could be some third gremlin. None of us in the User Community really have the insight into this level of the Firewall and VPN. Hopefully, you’ll get some relief from @xrobau (who is the guy that wrote the Firewall) or maybe @lgaetz (who is the guy that knows EVERYTHING).

Ok cynjut.

Just for your interest, I don’t use the builted in firewall of fpbx. In my oppinion, it’s probably a vpn config issue.

Best regards.


did anyone found a solution for this?
I did found out that the ‘reneg_sec’ value of both the cliend and server config of openvpn are related.
When setting both to a high value (1 day) the vpn is renegotiated every 24 hrs, when setting to 30 seconds, that happens every 30 seconds. During the renegotiation there is no audio.

The smallest value is leading.

There is no way to set those values from the Freepbx UI, the only way I was able to change this is by edeting the config files manually, and loading then them to the phone.
After a new config is created from the UI, the server config is reqwritten and back to the default value (3600) which makes the audio stop every hour for a few moments.

What we need is to change the skeletons or tools that create those files.

Any help is welcome.



That would call for a feature request.
The reneg_sec at 3600 is too low, an audio drop every hour is annoying.

I am using a VPN server that’s running on a different box, not on the Freepbx machine, and I have set the reneg_sec value to zero.
Well that works fine with yealink firmware V82 and lower. V83 and above there is a TLS reset happening every 48 minutes, causing the same audio drops.
I have no idea where the 48 minutes come from, but that’s what’s happening.

Hi Avayax,

thanks, I saw your post @ yealink forums. Did you try v84?
Anyways, the issue I have is not with V83 but lower, and as we are using Freepbx that’s what I want to keep using to setup the openvpn clients.

Hoping to have an Freepbx engineer pick this up.

You’ll need to file a feature request (if there isn’t one yet) so they can discuss this and possibly get it into FreePBX

This topic was automatically closed 365 days after the last reply. New replies are no longer allowed.