Feature codes not being recognised


When i dial *98 , *97 etc i just get silence, i suspect dtmf is not working properly , relevant settings i think :

RFC2833 - have tried changing this to all other options, no fix.

Asterisk Dial command options: Ttr
Asterisk Outbound Dial command options: Tt

I tried

Asterisk Dial command options: tTrwW
Asterisk Outbound Dial command options: T

no go

Any help appreciated


Just tested softphone, they work fine!

using avaya 4621sw phones

anyone got any ideas, feature codes ok on softphone , silence on desk phone?

hate to bump but :


Odd you should mention this, but I am having the same problem. Kinda important to get working :slight_smile:

Normal calls over avaya phones work? I don’t think its anything to do with dtmf…dtmf is used during a call/open channel…

I just have the same problem. I dial *43 for the echo test, and the call hangs.
A quick look at a wireshark trace shows that the phone does not acknowledge the 401 Unauthorized message from asterisk, so authentication ultimately fails. It is quite odd because dialing anything else works just fine. I suspect a bug in SIP firmware, or maybe something has to be setup on the phone configuration.
My firmware (SIP) is s10d01b_2_2_2.bin.

I’ll follow the thread in case someone comes up with a solution…

Sorry I forgot to mention my phone model: Avaya 4610SW