FreePBX | Register | Issues | Wiki | Portal | Support

Feature code issues


(Gcameron) #1

when trying to forward all calls from an extension I press *72 and get the message “agent logged off” I have no queues set up. The call logs looks like this:

Executing [*72@from-internal:1] Set("SIP/428-00000000", "__SIP_CODEC=g722                                                                                                                                                             ") in new stack
    -- Executing [*72@from-internal:2] Goto("SIP/428-00000000", "from-internal,*                                                                                                                                                             72,4") in new stack
    -- Goto (from-internal,*72,4)
    -- Executing [*72@from-internal:4] Set("SIP/428-00000000", "fromext=") in ne                                                                                                                                                             w stack
    -- Executing [*72@from-internal:5] GotoIf("SIP/428-00000000", "0?startread")                                                                                                                                                              in new stack
    -- Executing [*72@from-internal:6] Playback("SIP/428-00000000", "agent-logge                                                                                                                                                             doff") in new stack
    -- <SIP/428-00000000> Playing 'agent-loggedoff.g722' (language 'en')
    -- Executing [*72@from-internal:7] Macro("SIP/428-00000000", "hangupcall,")                                                                                                                                                              in new stack
    -- Executing [s@macro-hangupcall:1] GotoIf("SIP/428-00000000", "1?theend") i                                                                                                                                                             n new stack
    -- Goto (macro-hangupcall,s,3)
    -- Executing [s@macro-hangupcall:3] ExecIf("SIP/428-00000000", "0?Set(CDR(re                                                                                                                                                             cordingfile)=)") in new stack
    -- Executing [s@macro-hangupcall:4] NoOp("SIP/428-00000000", " montior file=                                                                                                                                                              ") in new stack
    -- Executing [s@macro-hangupcall:5] GotoIf("SIP/428-00000000", "1?skipagi")                                                                                                                                                              in new stack
    -- Goto (macro-hangupcall,s,7)
    -- Executing [s@macro-hangupcall:7] Hangup("SIP/428-00000000", "") in new st                                                                                                                                                             ack
  == Spawn extension (macro-hangupcall, s, 7) exited non-zero on 'SIP/428-000000                                                                                                                                                             00' in macro 'hangupcall'
  == Spawn extension (from-internal, *72, 7) exited non-zero on 'SIP/428-0000000                                                                                                                                                             0'
    -- Executing [h@from-internal:1] Macro("SIP/428-00000000", "hangupcall") in

(Lorne Gaetz) #2

This line was not generated by FreePBX. You have custom dialplan that is messing things up.


(Gcameron) #3

all the setting seem to match a different server we use on another campus. Any suggestions and where exactly to look?


(Chris Dolese) #4

extensions_custom.conf in /etc/asterisk

if its populated with anything its using custom dialplan


(Gcameron) #5

That file is blank. We have another server at a different campus and it does not have this issue. I have checked all of the setting I can think of and everything seems to match. I’m lost as what to look for next


#6

My guess is you inadvertently reassigned your agent login/ out to *72


(Lorne Gaetz) #7

What is the output of:

grep SIP_CODEC /etc/asterisk/*

(Gcameron) #8

The output of grep SIP_CODEC /etc/asterisk/* is:
/etc/asterisk/extensions_custom.conf:exten => _0.,1,Set(__SIP_CODEC=alaw)
/etc/asterisk/extensions_custom.conf:exten => _*.,1,Set(__SIP_CODEC=g722)


(Gcameron) #9

I have checked multiple times and even did a screen comparison to our other server and the feature code match exactly dicko


(Lorne Gaetz) #10

@dolesec told you exactly which file to look in, and the grep confirmed the same file. You have sloppy custom dialplan in /etc/asterisk/extensions_custom.conf


(Gcameron) #11

I am guessing this has nothing to do with the web Gui? I am going to have to fix this with the command line correct?


(Lorne Gaetz) #12

That or using the config edit module:
https://wiki.freepbx.org/display/FPG/Configuration+File+Editor+User+Guide


(Gcameron) #13

Thanks. I found the error and all is well now


(system) closed #14

This topic was automatically closed 7 days after the last reply. New replies are no longer allowed.