Fax

I have just installed the fax pro module and am trying to send faxes. They are failing. Here is what I believe is the pertinent info from the asterisk cli:

   > Channel Local/[email protected];1 was answered.

== Starting Local/[email protected];1 at send-fax,s,1 failed so falling back to exten ‘s’
== Starting Local/[email protected];1 at send-fax,s,1 still failed so falling back to context ‘default’
– Executing [[email protected]:1] Playback(“Local/[email protected];1”, “vm-goodbye”) in new stack
– <Local/[email protected];1> Playing ‘vm-goodbye.ulaw’ (language ‘en’)
– Executing [[email protected]:1] Macro(“Local/[email protected];2”, “hangupcall,”) in new stack
– Executing [[email protected]ngupcall:1] GotoIf(“Local/[email protected];2”, “1?theend”) in new stack
– Goto (macro-hangupcall,s,3)
– Executing [[email protected]:3] Hangup(“Local/[email protected];2”, “”) in new stack
== Spawn extension (macro-hangupcall, s, 3) exited non-zero on ‘Local/[email protected];2’ in macro ‘hangupcall’
== Spawn extension (macro-dialout-trunk, h, 1) exited non-zero on ‘Local/[email protected];2’
== Manager ‘admin’ logged off from 127.0.0.1
== Manager ‘admin’ logged off from 127.0.0.1
== Spawn extension (macro-dialout-trunk, s, 20) exited non-zero on ‘Local/[email protected];2’ in macro ‘dialout-trunk’
== Spawn extension (from-internal, 5412670378, 6) exited non-zero on ‘Local/[email protected];2’
– Executing [[email protected]:2] NoOp(“SIP/Bandwidth-California-00000003”, “ERROR: FreePBX Does not use the [default] context, confguration error”) in new stack

I am really not sure where to go from here. I am sending out over a SIP trunk. Using the FreePBX distro.

How are you originating the fax? I don’t see where You are uploading. The file. The way to send a fax is via the ARI. Your can’t use a fax machine.

I did upload from the ari

You need to provide much more log. Turn the debug level up (core set debug 50) and turn on fax debug (you will need to lookup the command).

As the log will be large post the contents of /var/log/asterisk/full starting at the timestamp of the fax upload to pastebin.ca and post the link to pastebin here.

Umm, I have another problem, apparently it stopped logging to /var/lob/asterisk/full on Sept. 2nd. I have no idea why. I can get a cli printout with those settings, but not the full file. I’ll be working on that, any ideas there would be appreciated too.

Here is the link to the cli output:
http://pastebin.ca/2080617

WRT the logging problem take a look at ‘logger show channels’ and see what is up with the logging.

As far as the FAX, impossible to tell without the debug but it looks like bandwidth is simply not negotiating t.38.

logger show channels gives:
Channel Type Status Configuration


and that’s it, so that’s not right, I don’t know where to set that.

I didn’t know the fax module was using t.38, I thought it was sending it in the rtp stream.

SkykingOH, How do you send a fax from ARI? Do you have to load something special? I have been using ARI for a couple years, and mine in FreePBX 2.9 doesn’t look any different. Thank you.

I have just successfully set up inbound faxing using Digium modems. Loaded the FFA and one paid license. The Digium support rocks. Buy their modems.

You have to use the Custom Desintations, as recommended herein. Then you have to create a custom context in /etc/asterisk/extensions_custom.conf

If anyone needs help let me know. Unless you are strong with the Asterisk Dial Plan this is a hard one.

We are confusing issues here.

The Fax Pro is a commercial module from Schmooze, it works with both FFA, a Digium Product and SpanDSP. SpanDSP is a completely open source solution.

The Fax Pro module adds the ability to setup cover pages and fax from the ARI.

I got the log working. The contents of /etc/asterisk/logger_general_custom.conf and …logger_logfiles_custom.conf were both empty. I put in what was on one of my other fpbx distro boxes and it is now working. The contents of it while trying to send a fax via the ARI are at:
http://pastebin.ca/2080702

Ok a few things:

: Unsupported SDP media type in offer: video 0 RTP/AVP 34 99

Need to make sure you have video disabled on the trunk.

Next, you need to have fax debug turned on to confirm my idea.

I would also run one more log with debug and verbose set to 0, fax debug turned off and sip debug turned on just for the peer bandwidth-california.

With that data would should be able to get close.

Also, post your trunk config.

Ok, well I ended up setting up another system to take that ones place, as it was my office system and so I could do that, and it works as soon as everything was setup. Not sure what the issue was…