Fax to email, PDF is empty (0Kb)

Hi I’ve installed trixbox CE 2.6.1 (which I think uses FreePBX 2.3) and tried out the fax to email. It almost works but the pdf attachment is 0KB and contains no data.

The fax appears in /var/spool/asterisk/fax as a *.tif file and when viewing the .tif it is all good.

If I run tiff2pdf manually on the file it creates a working pdf of the tif file. So tiff2pdf is installed and working correctly.

I ran a module update on my trixbox machine as well, hoping that would fix it.

I have run the following command as root:

./fax-process.pl --file /var/spool/asterisk/fax/1220488289.4.tif --to [email protected] --from [email protected] --subject “Fax from xxxxxxxx xxxxxxx” --attachment fax_xxxxxxx.pdf --type application/pdf

The emails and numbers up above have been altered for privacy, of course.

It does the same thing, it sends me a blank PDF by email. So it’s not a permissions problem. It seems there is something wrong with fax-process.pl but I can’t read perl so can’t see a problem.