Fax to email, am I missing something?

I have successfully setup my FreePbx and it is running everything perfectly, except the integrated fax. This is my current setup: My box is behind a Netgear FVS318 router, with a dynamic ip adress. I have configured my router to update my dyndns host automatically, no issues with this. Attached to the box I have two Spa3102 Fxo/Fxs gateways, one inside the same network as the asterisk box, and another one with a public ip. In addition to the Spa’s, I have a few softphone extensions. As I said everything works fine I can call both trunks from any phone, and my voice mail sends is sending e-mail notifications without any trouble.

The issue that I am having is receiving faxes from one of my Spa 3102 trunk, so it can then be handled by the mail server and sent to an e-mail address. I have read a few “How-To’s” but I think I’m missing something. In general settings I have set the fax to be handled by “system” and filled in both email fields. On my inbound route for the trunk I am trying to receive the fax, I have set the extension to Free PBX default, Fax detection to NVFax, and pause after answer from 1-6. Every time I try to send this trunk a fax, I hear the beep for the invite, but it continues to ring. This happens as it is not detecting a fax invitation. How can I go about solving this problem? Is there additional configuration needed in the PSTN tab of my Spa3102, or is there an additional configuration/module to be setup in my asterisk box.
Lol this is driving me crazy, but at least everything else seems to be working properly. Oh I forgot to mention that I have an IVR on the trunk that I want to receive faxes from, but I think the fax happens before the IVR comes in.

Juan Perez

If you installed Asterisk from Source, you will need to recompile it with support for NVFax - here is the VoIP-Info.org page about FAXing:


Also, NerdVittles has a nice write up about FAX - here it is:


Finally, here is an article here about it: