Fax Pro Uninstall or Removal crashes

I’m glad my system is on a VM… I’ve often broke my newly installed Freepbx when performing updates.

Normally, I will “revert” the VM to last working state, and will try less updates, or change the sequence of the updates, to get my system up to date.

Today, I decided that I wanted to remove the modules I am not planning on using ever. FAX Pro and FAX were on my list.

First, I found out rather quickly that FAX PRO was to be uninstalled/ removed first. Tried to uninstall: broke the PBX. Reverted, tried to REMOVE: broke the PBX with the same message:

5. die_freepbx
4. include_once
3. module_functions _doinclude
2. module_functions _runscripts

  1. module_functions uninstall
  2. include
    _Can not execute ALTER TABLE fax_users DROP faxlocalstore, DROP faxstationid, DROP faxheader, DROP faxcovername, DROP faxcovertel, DROP faxcoveremail; : SQLSTATE[42000]: Syntax error or access violation: 1091 Can’t DROP ‘faxlocalstore’; check that column/key exists ::
    if(is_object($extended_text) && method_exists($extended_text,“getMessage”)) {
    $e = $extended_text;
    $extended_text = htmlentities($e->getMessage());
    $code = $e->getCode();
    throw new \Exception($text . “::” . $extended_text,$code,$e);
    } else {
    $extended_text = htmlentities($extended_text);
    throw new \Exception($text . “::” . $extended_text);
  • Any idea why I run into that ‘Exception’ page more often than I would hope? Something I’m doing wrong?

Thank you!

Because uninstall of modules is rarely done so nobody caught this. Open a bug report.