Fax Pro Outbound Fax Resolution

I am using the faxpro module and am having image quality issues. The dpi or resolution of the text and images is very low when sending faxes. Inbound faxes look fine. I am looking for any settings that may help adjust the quality of outbound faxes. I am on Freepbx 12.0.64 Asterisk V11.15.0

Unfortunately res_fax in asterisk just reads the resolution of the doc and uses that.

I’m having the same issue. The original PDF is 300dpi so I don’t think its a dpi issue. It seems to be pdf’s that were created from a scanner that cause the issue. Here is a screenshot showing the original PDF (top) and then the same text on the PDF confirmation I receive back from FreePBX.

Is there some way to fix this?


Freepbx 12.0.67

I am having the same problem as clifforg (19 june 2015),

The cover pages transmits perfectly, but all of the pages from the PDF file are blurred. I generated PDF file with gray scale color and 200 and 300 dpi; both lead to the same result. When I generated it as a B&W PDF file it was worse.

These are scanned documents coming in thru a TWAIN interface. Is there a preferred document type that will work better?

We are aware of this issue and have a bug to address it soon.

Is there any update on this? I’ve just installed Faxpro for a customers and am getting the same issues.



Not at this time…

OK, its been 4 months with this bug outstanding. Given this is a “paid” module, I had expectations the problem would have been solved by now.

Can anyone explain why a fix hasn’t been released? Or better yet, just fix the bug!

This hasn’t been fixed because it’s more of a feature request than a bug. Also priorities lay on releasing and making freepbx 13 stable. After that happens then we get to issues like these

Tracking ticket: http://issues.freepbx.org/browse/FREEPBX-9404

I have upped the default setting to “fine” in faxpro v13.0.17. In the coming weeks you will be able to select standard, fine or superfine.

Let me know if this helps in the meantime.

1 Like

Any Update for asterisk 11.18, I’m having the same problem?

This has nothing to do with Asterisk versions. Only FreePBX versions.

I’m Talking about Freepbx 12 with asterisk 11.18 in Cyberlynk, I’m having this problem and I don’t know how to fix it, thank you Freepbx Fax Pro

You need to upgrade to FreePBX 13 and then get the newest FaxPro. That is the only way.

I’m sorry but I don’t know why I have to upgrade to Freepbx if still BETA, we paid for Fax pro and we didn’t see any restriction with the quality for outbound faxes, Why Sangoma don’t fix it for freepbx 12 that it’s the version we use for fax pro? it was supposed to be 100 before sell it

The feature was added in FreePBX 13. I am not sure how we are to explain that the quality of faxes was low, in fact it was fine for most users? It was a feature request a user made and we implemented it into FreePBX 13. That is how features usually go. They are added into the next release to keep the current release stable

Also FreePBX 13 is not beta.

what is the best way to upgrade from freepbx 12 to 13 without problem

Get sysadmin pro and upgrade from FreePBX GUI.

I did it and now, an SPA 122 we had to receive fax is not working anymore every time I dial the extension I got 302 error and the fax is not working anymore, any Idea?

Don’t know.
You would have to be more specific about what is failing exactly, paste logs, etc.
And for commercial modules you can always open a ticket with Schmooze.