Fax not working after a new installation

I recently installed FreePBX Distro. All is working fine besides faxing. I am hoping to resolve this issue so I can upgrade from Trixbox.

I am currently using Trixbox for our phone system. I decided to upgrade the system with FreePBX distro since Trixbox is no longer supported and it is getting old. I am using 2 Rhino cards inside my server , an R24FXX (8FXX and 2FXo) and R2T1 (2 PRI)

Those are the steps I took in order to upgrade my system:
I removed my 2 mirroring drives (Trixbox installation ) and installed 2 new drives.
I removed the 2 rhino cards
I installed the Freepbx Distro from a CD that I burnt and follow the instruction from Freepbx site.
after all the updates and the initial configuration I shutdown the server and reinstalled the cards

Freepbx found the 2 cards and installed them properly

I configured my extensions and plugged my 2 PRI lines into it.

Everything works properly besides my faxes , when I send a fax from one of my fax to another fax that I have , the fax ring , pickup the call , start to do the negotiation signaling and then the call hangs up with no fax. I tried to send from both directions, and I also tried from direct extension to bypass the provider in case the issue was coming from the provider.

I plugged an analog phone to the fax line and made a call and it works fine.

I am not sure what’s causing the issue to not have fax talking to another fax machine.

I removed the drives and plug back my old Trixbox drives and tested the fax and it worked. so I reinserted my 2 drives with FreePBX on it and tested again and it doesn’t work.

Any help would be appreciate.